summaryrefslogtreecommitdiffstats
path: root/package/dmalloc
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/dmalloc
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/dmalloc')
-rw-r--r--package/dmalloc/dmalloc.mk18
1 files changed, 12 insertions, 6 deletions
diff --git a/package/dmalloc/dmalloc.mk b/package/dmalloc/dmalloc.mk
index 360a66f7e..31aea34b7 100644
--- a/package/dmalloc/dmalloc.mk
+++ b/package/dmalloc/dmalloc.mk
@@ -34,6 +34,17 @@ $(DMALLOC_DIR)/.configured: $(DMALLOC_DIR)/.unpacked
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
--enable-threads \
--enable-shlib \
);
@@ -43,12 +54,7 @@ $(DMALLOC_DIR)/$(DMALLOC_BINARY): $(DMALLOC_DIR)/.configured
$(MAKE) -C $(DMALLOC_DIR)
$(TARGET_DIR)/$(DMALLOC_TARGET_BINARY): $(DMALLOC_DIR)/$(DMALLOC_BINARY)
- $(MAKE) prefix=$(STAGING_DIR)/usr \
- exec_prefix=$(TARGET_DIR)/usr \
- libdir=$(STAGING_DIR)/usr/lib \
- shlibdir=$(TARGET_DIR)/usr/lib \
- includedir=$(STAGING_DIR)/include \
- -C $(DMALLOC_DIR) install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(DMALLOC_DIR) install
(cd $(STAGING_DIR)/usr/lib; \
mv libdmalloc*.so $(TARGET_DIR)/usr/lib);
touch $(TARGET_DIR)/$(DMALLOC_TARGET_BINARY)