summaryrefslogtreecommitdiffstats
path: root/package/distcc
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /package/distcc
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
downloadbuildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.tar.gz
buildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.zip
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'package/distcc')
-rw-r--r--package/distcc/distcc.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/package/distcc/distcc.mk b/package/distcc/distcc.mk
new file mode 100644
index 000000000..529f37fce
--- /dev/null
+++ b/package/distcc/distcc.mk
@@ -0,0 +1,58 @@
+#############################################################
+#
+# distcc
+#
+#############################################################
+DISTCC_VER:=2.17
+DISTCC_SOURCE:=distcc-$(DISTCC_VER).tar.bz2
+DISTCC_SITE:=http://distcc.samba.org/ftp/distcc/
+DISTCC_DIR:=$(BUILD_DIR)/distcc-$(DISTCC_VER)
+DISTCC_BINARY:=distcc
+DISTCC_TARGET_BINARY:=usr/bin/distcc
+
+$(DL_DIR)/$(DISTCC_SOURCE):
+ $(WGET) -P $(DL_DIR) $(DISTCC_SITE)/$(DISTCC_SOURCE)
+
+$(DISTCC_DIR)/.unpacked: $(DL_DIR)/$(DISTCC_SOURCE)
+ bzcat $(DL_DIR)/$(DISTCC_SOURCE) | tar -C $(BUILD_DIR) -xf -
+ touch $(DISTCC_DIR)/.unpacked
+
+$(DISTCC_DIR)/.configured: $(DISTCC_DIR)/.unpacked
+ (cd $(DISTCC_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD=$(HOSTCC) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --with-included-popt \
+ --without-gtk \
+ --without-gnome \
+ );
+ touch $(DISTCC_DIR)/.configured
+
+$(DISTCC_DIR)/$(DISTCC_BINARY): $(DISTCC_DIR)/.configured
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) CC=$(TARGET_CC) -C $(DISTCC_DIR)
+
+$(TARGET_DIR)/$(DISTCC_TARGET_BINARY): $(DISTCC_DIR)/$(DISTCC_BINARY)
+ install -D $(DISTCC_DIR)/$(DISTCC_BINARY)d $(TARGET_DIR)/$(DISTCC_TARGET_BINARY)d
+ install -D $(DISTCC_DIR)/$(DISTCC_BINARY) $(TARGET_DIR)/$(DISTCC_TARGET_BINARY)
+
+distcc: uclibc $(TARGET_DIR)/$(DISTCC_TARGET_BINARY)
+
+distcc-clean:
+ rm -f $(TARGET_DIR)/$(DISTCC_TARGET_BINARY)
+ rm -f $(TARGET_DIR)/$(DISTCC_TARGET_BINARY)d
+ -$(MAKE) -C $(DISTCC_DIR) clean
+
+distcc-dirclean:
+ rm -rf $(DISTCC_DIR)