summaryrefslogtreecommitdiffstats
path: root/package/directfb/directfb.mk
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-08-06 12:28:15 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-07 19:03:34 +0200
commitdfc4deffd4dca7dfbd81ae8539f74231e3fd3806 (patch)
treeb0a44ed653942470823e52e65d0802e848f5c9b9 /package/directfb/directfb.mk
parent5e64f5057b2485e02cce431eb5d82e5cb8048fef (diff)
downloadbuildroot-novena-dfc4deffd4dca7dfbd81ae8539f74231e3fd3806.tar.gz
buildroot-novena-dfc4deffd4dca7dfbd81ae8539f74231e3fd3806.zip
directfb: allow to enable debug and trace support
This change adds two new options, BR2_PACKAGE_DIRECTFB_DEBUG to enable lots of debugging output from DirectFB and BR2_PACKAGE_DIRECTFB_TRACE to enable support for call traces in case of a crash. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Diffstat (limited to 'package/directfb/directfb.mk')
-rw-r--r--package/directfb/directfb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 93b45938d..2407743dd 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -19,6 +19,19 @@ else
DIRECTFB_MULTI:=
DIRECTFB_FUSION:=
endif
+
+ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
+DIRECTFB_DEBUG:=--enable-debug
+else
+DIRECTFB_DEBUG:=
+endif
+
+ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
+DIRECTFB_TRACE:=--enable-trace
+else
+DIRECTFB_TRACE:=
+endif
+
ifeq ($(BR2_PACKAGE_XSERVER),y)
DIRECTFB_X:=--enable-x11
else
@@ -111,6 +124,8 @@ DIRECTFB_CONF_OPT = \
--enable-shared \
--disable-explicit-deps \
$(DIRECTFB_MULTI) \
+ $(DIRECTFB_DEBUG) \
+ $(DIRECTFB_TRACE) \
$(DIRECTFB_X) \
$(DIRECTFB_JPEG) \
$(DIRECTFB_PNG) \