summaryrefslogtreecommitdiffstats
path: root/package/directfb/directfb.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-04-06 17:40:47 +0000
committerEric Andersen <andersen@codepoet.org>2006-04-06 17:40:47 +0000
commitb607f5cdc3bc1c14ca3b049ea9f3b5de39883869 (patch)
tree617e3ec819701b06ae9a86c2785ff233ef23f3c3 /package/directfb/directfb.mk
parent5c08468027f868f1c301075c3a288208168bbbd0 (diff)
downloadbuildroot-novena-b607f5cdc3bc1c14ca3b049ea9f3b5de39883869.tar.gz
buildroot-novena-b607f5cdc3bc1c14ca3b049ea9f3b5de39883869.zip
tyler writes:
Building DirectFB compiles fine and installs fine, but when running on the target the libraries look for DirectFB modules within a path that was defined as $(PREFIX) during the build. Under buildroot PREFIX is set to $(STAGING_DIR)/usr, which obviously doesn't exist on the target so it dies. Instead, it should be built such that PREFIX=/usr then have prefix & exec_prefix set to $(STAGING_DIR)/usr when it's time to install.
Diffstat (limited to 'package/directfb/directfb.mk')
-rw-r--r--package/directfb/directfb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 9ff293ade..51062a865 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -30,7 +30,7 @@ $(DIRECTFB_DIR)/.configured: $(DIRECTFB_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
- --prefix=$(STAGING_DIR)/usr \
+ --prefix=/usr \
--with-gfxdrivers=cle266,unichrome \
--enable-jpeg \
--enable-png \
@@ -48,7 +48,7 @@ $(DIRECTFB_DIR)/.compiled: $(DIRECTFB_DIR)/.configured
touch $(DIRECTFB_DIR)/.compiled
$(STAGING_DIR)/usr/lib/libdirectfb.so: $(DIRECTFB_DIR)/.compiled
- $(MAKE) -C $(DIRECTFB_DIR) install
+ $(MAKE) -C $(DIRECTFB_DIR) install prefix=$(STAGING_DIR)/usr exec_prefix=$(STAGING_DIR)/usr
touch -c $(STAGING_DIR)/lib/libdirectfb.so
$(TARGET_DIR)/usr/lib/libdirectfb.so: $(STAGING_DIR)/usr/lib/libdirectfb.so