summaryrefslogtreecommitdiffstats
path: root/package/directfb/directfb.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/directfb/directfb.mk
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/directfb/directfb.mk')
-rw-r--r--package/directfb/directfb.mk43
1 files changed, 27 insertions, 16 deletions
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 4fb9a36b7..38a6403a5 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -27,21 +27,32 @@ $(DIRECTFB_DIR)/.configured: $(DIRECTFB_DIR)/.unpacked
ac_cv_header_linux_wm97xx_h=no \
ac_cv_header_linux_sisfb_h=no \
./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --with-gfxdrivers=cle266,unichrome \
- --enable-jpeg \
- --enable-png \
- --enable-linux-input \
- --enable-zlib \
- --enable-freetype \
- --enable-sysfs \
- --disable-sdl \
- --disable-video4linux \
- --disable-video4linux2 \
- --disable-fusion );
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/usr/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --with-gfxdrivers=cle266,unichrome \
+ --enable-jpeg \
+ --enable-png \
+ --enable-linux-input \
+ --enable-zlib \
+ --enable-freetype \
+ --enable-sysfs \
+ --disable-sdl \
+ --disable-video4linux \
+ --disable-video4linux2 \
+ --disable-fusion );
touch $(DIRECTFB_DIR)/.configured
$(DIRECTFB_DIR)/.compiled: $(DIRECTFB_DIR)/.configured
@@ -49,7 +60,7 @@ $(DIRECTFB_DIR)/.compiled: $(DIRECTFB_DIR)/.configured
touch $(DIRECTFB_DIR)/.compiled
$(STAGING_DIR)/usr/lib/libdirectfb.so: $(DIRECTFB_DIR)/.compiled
- $(MAKE) -C $(DIRECTFB_DIR) install prefix=$(STAGING_DIR)/usr exec_prefix=$(STAGING_DIR)/usr
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(DIRECTFB_DIR) install
touch -c $(STAGING_DIR)/lib/libdirectfb.so
$(TARGET_DIR)/usr/lib/libdirectfb.so: $(STAGING_DIR)/usr/lib/libdirectfb.so