summaryrefslogtreecommitdiffstats
path: root/package/directfb-examples
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-12-26 23:28:15 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-12-26 23:28:15 +0000
commitf1c00c93d45e0fe7d0c851dc9a2ba5de16530c5d (patch)
tree791525d2ac859c609d155b7bea4996ced8b70da1 /package/directfb-examples
parent5d83c7ac4bab92e5891b505d1ab4c7e142088bfb (diff)
downloadbuildroot-novena-f1c00c93d45e0fe7d0c851dc9a2ba5de16530c5d.tar.gz
buildroot-novena-f1c00c93d45e0fe7d0c851dc9a2ba5de16530c5d.zip
directfb-examples fixes
* Do not install to the staging dir inside the target install target, since it has already been done in the staging install target. * Strip the binaries installed in the target. * Properly create the target installation stamp. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/directfb-examples')
-rw-r--r--package/directfb-examples/directfb-examples.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/directfb-examples/directfb-examples.mk b/package/directfb-examples/directfb-examples.mk
index 83063cc42..065f720b7 100644
--- a/package/directfb-examples/directfb-examples.mk
+++ b/package/directfb-examples/directfb-examples.mk
@@ -42,14 +42,13 @@ $(eval $(call AUTOTARGETS,package,directfb-examples))
$(DIRECTFB_EXAMPLES_TARGET_INSTALL_TARGET): $(DIRECTFB_EXAMPLES_TARGET_INSTALL_STAGING)
$(call MESSAGE,"Installing to target")
- $(MAKE) DESTDIR=$(STAGING_DIR) -C $(DIRECTFB_EXAMPLES_DIR) install
$(Q)mkdir -p $(TARGET_DIR)/usr/bin
$(Q)mkdir -p $(TARGET_DIR)/usr/share/directfb-examples/
$(Q)mkdir -p $(TARGET_DIR)/usr/share/directfb-examples/fonts/
for file in $(DIRECTFB_EXAMPLES_TARGETS_y); do \
cp -dpf $(STAGING_DIR)/$$file $(TARGET_DIR)/$$file; \
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/$$file; \
done
-
$(Q)cp -rdpf $(STAGING_DIR)/usr/share/directfb-examples/fonts/decker.ttf $(TARGET_DIR)/usr/share/directfb-examples/fonts/
ifeq ($(BR2_PACKAGE_DIRECTFB_EXAMPLES_ANDI),y)
$(Q)cp -rdpf $(STAGING_DIR)/usr/share/directfb-examples/destination_mask.png $(TARGET_DIR)/usr/share/directfb-examples/
@@ -101,5 +100,5 @@ ifeq ($(BR2_PACKAGE_DIRECTFB_EXAMPLES_WINDOW),y)
$(Q)cp -rdpf $(STAGING_DIR)/usr/share/directfb-examples/desktop.png $(TARGET_DIR)/usr/share/directfb-examples/
$(Q)cp -rdpf $(STAGING_DIR)/usr/share/directfb-examples/dfblogo.png $(TARGET_DIR)/usr/share/directfb-examples/
endif
- $(Q)touch -c $@
+ touch $@