summaryrefslogtreecommitdiffstats
path: root/package/dhcpcd
diff options
context:
space:
mode:
authorJohn Stile <johns@msli.com>2013-03-10 18:23:14 -0700
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-18 08:45:47 +0200
commit69a0a1e1d369fc2312b741f009bcecaf1ee33798 (patch)
tree111086cf5682b54f4bc9fb5e0a6a5fccd9578fac /package/dhcpcd
parent4630a6a8472a0f9f30fbacbefde7c45d6507156a (diff)
downloadbuildroot-novena-69a0a1e1d369fc2312b741f009bcecaf1ee33798.tar.gz
buildroot-novena-69a0a1e1d369fc2312b741f009bcecaf1ee33798.zip
dhcpcd: new package
Dhcpcd is an RFC2131 compliant DHCP client. [Peter: needs ipv6, fix whitespace/file header] Signed-off-by: John Stile <john@stilen.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dhcpcd')
-rw-r--r--package/dhcpcd/Config.in10
-rw-r--r--package/dhcpcd/dhcpcd.mk42
2 files changed, 52 insertions, 0 deletions
diff --git a/package/dhcpcd/Config.in b/package/dhcpcd/Config.in
new file mode 100644
index 000000000..a06a9730e
--- /dev/null
+++ b/package/dhcpcd/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_DHCPCD
+ depends on BR2_INET_IPV6
+ bool "dhcpcd"
+ help
+ An RFC2131 compliant DHCP client
+
+ http://roy.marples.name/downloads/dhcpcd
+
+comment "dhcpcd requires a toolchain with IPV6 support"
+ depends on !BR2_INET_IPV6
diff --git a/package/dhcpcd/dhcpcd.mk b/package/dhcpcd/dhcpcd.mk
new file mode 100644
index 000000000..9d4a72beb
--- /dev/null
+++ b/package/dhcpcd/dhcpcd.mk
@@ -0,0 +1,42 @@
+################################################################################
+#
+# dhcpcd
+#
+################################################################################
+
+DHCPCD_VERSION = 5.6.7
+DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.bz2
+DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd/
+DHCPCD_LICENSE = BSD-2c
+
+ifeq ($(BR2_USE_MMU),)
+ DHCPCD_CONFIG_OPT += --disable-fork
+endif
+
+define DHCPCD_CONFIGURE_CMDS
+ (cd $(@D); \
+ ./configure \
+ --target=$(BR2_GCC_TARGET_ARCH) \
+ --os=linux \
+ $(DHCPCD_CONFIG_OPT) )
+endef
+
+define DHCPCD_BUILD_CMDS
+ $(MAKE) \
+ $(TARGET_CONFIGURE_OPTS) \
+ -C $(@D) all
+endef
+
+define DHCPCD_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/dhcpcd \
+ $(TARGET_DIR)/usr/bin/dhcpcd
+ $(INSTALL) -D -m 0644 $(@D)/dhcpcd.conf \
+ $(TARGET_DIR)/etc/dhcpcd.conf
+ $(INSTALL) -D -m 0755 $(@D)/dhcpcd-run-hooks \
+ $(TARGET_DIR)/libexec/dhcpcd-run-hooks
+endef
+
+# NOTE: Even though this package has a configure script, it is not generated
+# using the autotools, so we have to use the generic package infrastructure.
+
+$(eval $(call generic-package))