summaryrefslogtreecommitdiffstats
path: root/package/dbus
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /package/dbus
parentf58ff9a25f24576e032c65d762e5b8fdd2cf5c1c (diff)
downloadbuildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.tar.gz
buildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.zip
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk38
1 files changed, 18 insertions, 20 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 02ad624f3..af82bf2bd 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -56,23 +56,22 @@ $(DBUS_HOOK_POST_INSTALL): $(DBUS_TARGET_INSTALL_TARGET)
# dbus for the host
DBUS_HOST_DIR:=$(BUILD_DIR)/dbus-$(DBUS_VERSION)-host
-DBUS_HOST_BINARY:=$(HOST_DIR)/usr/bin/dbus-daemon
DBUS_HOST_INTROSPECT:=$(DBUS_HOST_DIR)/introspect.xml
-$(DBUS_HOST_DIR)/.unpacked: $(DL_DIR)/$(DBUS_SOURCE)
- mkdir -p $(@D)
+$(STAMP_DIR)/host_dbus_unpacked: $(DL_DIR)/$(DBUS_SOURCE)
+ mkdir -p $(DBUS_HOST_DIR)
$(INFLATE$(suffix $(DBUS_SOURCE))) $< | \
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(DBUS_HOST_DIR) $(TAR_OPTIONS) -
touch $@
-$(DBUS_HOST_DIR)/.configured: $(DBUS_HOST_DIR)/.unpacked $(EXPAT_HOST_BINARY)
- (cd $(@D); rm -rf config.cache; \
+$(STAMP_DIR)/host_dbus_configured: $(DBUS_HOST_DIR)/.unpacked $(STAMP_DIR)/host_expat_installed $(STAMP_DIR)/host_pkgconfig_installed
+ (cd $(DBUS_HOST_DIR); rm -rf config.cache; \
$(HOST_CONFIGURE_OPTS) \
CFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)" \
- $(@D)/configure \
- --prefix=$(HOST_DIR)/usr \
- --sysconfdir=$(HOST_DIR)/etc \
+ ./configure \
+ --prefix="$(HOST_DIR)/usr" \
+ --sysconfdir="$(HOST_DIR)/etc" \
--with-dbus-user=dbus \
--disable-tests \
--disable-asserts \
@@ -87,25 +86,24 @@ $(DBUS_HOST_DIR)/.configured: $(DBUS_HOST_DIR)/.unpacked $(EXPAT_HOST_BINARY)
)
touch $@
-$(DBUS_HOST_DIR)/.compiled: $(DBUS_HOST_DIR)/.configured
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+$(STAMP_DIR)/host_dbus_compiled: $(STAMP_DIR)/host_dbus_configured
+ $(HOST_MAKE_ENV) $(MAKE) -C $(DBUS_HOST_DIR)
touch $@
-$(DBUS_HOST_BINARY): $(DBUS_HOST_DIR)/.compiled
- $(MAKE) -C $(<D) install
-
-$(DBUS_HOST_INTROSPECT): $(DBUS_HOST_BINARY)
- $(DBUS_HOST_BINARY) --introspect > $@
+$(STAMP_DIR)/host_dbus_installed: $(STAMP_DIR)/host_dbus_compiled
+ $(MAKE) -C $(DBUS_HOST_DIR) install
+ $(HOST_DIR)/usr/bin/dbus-daemon --introspect > $(DBUS_HOST_INTROSPECT)
+ touch $@
-host-dbus: $(DBUS_HOST_INTROSPECT)
+host-dbus: $(STAMP_DIR)/host_dbus_installed
host-dbus-source: dbus-source
host-dbus-clean:
- rm -f $(addprefix $(DBUS_HOST_DIR)/,.unpacked .configured .compiled)
+ rm -f $(addprefix $(STAMP_DIR)/host_dbus_,unpacked configured compiled installed)
rm -f $(DBUS_HOST_INTROSPECT)
- $(MAKE) -C $(DBUS_HOST_DIR) uninstall
- $(MAKE) -C $(DBUS_HOST_DIR) clean
+ -$(MAKE) -C $(DBUS_HOST_DIR) uninstall
+ -$(MAKE) -C $(DBUS_HOST_DIR) clean
host-dbus-dirclean:
rm -rf $(DBUS_HOST_DIR)