summaryrefslogtreecommitdiffstats
path: root/package/dbus
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-04-21 15:10:39 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-04-21 15:10:39 +0000
commite493fc6ce5202ac008cb71ae9d5816ad11919d47 (patch)
treecf837ae1990f383c2287b9021d33dd2a8fdf7832 /package/dbus
parentf9c5711c07232f8a1c00562ebc911b4604652b14 (diff)
downloadbuildroot-novena-e493fc6ce5202ac008cb71ae9d5816ad11919d47.tar.gz
buildroot-novena-e493fc6ce5202ac008cb71ae9d5816ad11919d47.zip
dbus: fix rebuild if /var/lib is a symlink to /tmp for target
/tmp/dbus will end up being a recursive symlink to itself on the build host.
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index b987b1c26..7326b419b 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -50,6 +50,11 @@ endif
$(eval $(call AUTOTARGETS,package,dbus))
+# fix rebuild if /var/lib is a symlink to /tmp
+$(DBUS_HOOK_POST_BUILD): $(DBUS_TARGET_BUILD)
+ rm -rf /tmp/dbus
+ touch $@
+
$(DBUS_HOOK_POST_INSTALL): $(DBUS_TARGET_INSTALL_TARGET)
rm -rf $(TARGET_DIR)/usr/lib/dbus-1.0
rm -rf $(TARGET_DIR)/var/lib/dbus