summaryrefslogtreecommitdiffstats
path: root/package/dbus
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-31 18:39:55 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-31 18:39:55 +0000
commit398dfc42b7896def95b54721fab79067a6bc7f93 (patch)
tree220091f6d8997e632c4a9e0226df8e18ebed4705 /package/dbus
parent657563f2d7284e2e2a6129764ccab0fb1dcfe664 (diff)
downloadbuildroot-novena-398dfc42b7896def95b54721fab79067a6bc7f93.tar.gz
buildroot-novena-398dfc42b7896def95b54721fab79067a6bc7f93.zip
dbus: revert to pre-r25021 situation
Revert to pre-r25021 situation, but add extra comments explaining the situation.
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk20
1 files changed, 11 insertions, 9 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 8f1ac6d17..92405bd5b 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -13,10 +13,18 @@ DBUS_TARGET_BINARY:=usr/bin/dbus-daemon
ifeq ($(BR2_DBUS_EXPAT),y)
DBUS_XML:=expat
-DBUS_XML_DEP:=expat
+# depend on the exact library file instead of expat so dbus isn't always
+# considered out-of-date
+DBUS_XML_DEP:=$(STAGING_DIR)/usr/lib/libexpat.so.1
else
DBUS_XML:=libxml
-DBUS_XML_DEP:=libxml2
+# Makefile.autotools.in unfortunately has broken dependency handling,
+# so we cannot do the same for libxml2 as the targets (like
+# libxml2-install-staging) are phony and hence, dbus will always be
+# considered out-of-date. Using the corresponding .stamp_* files (E.G.
+# LIBXML2_TARGET_INSTALL_STAGING doesn't work as there's no dependency
+# information between them.
+DBUS_XML_DEP:=libxml2-install-staging
endif
$(DL_DIR)/$(DBUS_SOURCE):
@@ -86,7 +94,7 @@ ifneq ($(BR2_HAVE_MANPAGES),y)
rm -rf $(TARGET_DIR)/usr/share/man
endif
-dbus: uclibc pkgconfig $(DBUS_XML_DEP) $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
+dbus: uclibc pkgconfig $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
dbus-clean:
rm -f $(TARGET_DIR)/etc/dbus-1/session.conf
@@ -113,9 +121,3 @@ dbus-dirclean:
ifeq ($(BR2_PACKAGE_DBUS),y)
TARGETS+=dbus
endif
-
-dbus-status:
- @echo BR2_DBUS_EXPAT=$(BR2_DBUS_EXPAT)
- @echo DBUS_XML=$(DBUS_XML)
- @echo DBUS_XML_DEP=$(DBUS_XML_DEP)
-