summaryrefslogtreecommitdiffstats
path: root/package/dbus
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-14 01:23:34 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-14 01:23:34 +0100
commit24cb62ed4c7c3e0aa36500cc4d1c0b13ee722f71 (patch)
tree3ce105a6a42bfa35d8fdba41aa9da896b576981e /package/dbus
parent49f16f4b97abb888e918ce3d70d8a26f03db05c1 (diff)
downloadbuildroot-novena-24cb62ed4c7c3e0aa36500cc4d1c0b13ee722f71.tar.gz
buildroot-novena-24cb62ed4c7c3e0aa36500cc4d1c0b13ee722f71.zip
dbus: fix build on microblaze
Fixes http://autobuild.buildroot.net/results/5963d35b8933c452b8574c964e407c23a5d0412f The microblaze toolchain has sys/inotify.h, but doesn't provide inotify_rm_* functions, so disable inotify support. Also disable the legacy dnotify support (which is used when inotify support is disabled) as it has bitrotten upstream and no longer builds. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index b7cc37820..ec42874b6 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -18,11 +18,16 @@ DBUS_CONF_OPT = --with-dbus-user=dbus \
--disable-xml-docs \
--disable-doxygen-docs \
--disable-static \
- --enable-dnotify \
+ --disable-dnotify \
--localstatedir=/var \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-system-pid-file=/var/run/messagebus.pid
+ifeq ($(BR2_microblaze),y)
+# microblaze toolchain doesn't provide inotify_rm_* but does have sys/inotify.h
+DBUS_CONF_OPT += --disable-inotify
+endif
+
ifeq ($(BR2_DBUS_EXPAT),y)
DBUS_CONF_OPT += --with-xml=expat
DBUS_DEPENDENCIES += expat