summaryrefslogtreecommitdiffstats
path: root/package/dbus
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2013-06-29 09:27:04 -0400
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-29 21:03:34 +0200
commit0cf8595f2996b46143c1a95d3bd6f4e131a94b94 (patch)
tree1efa4a0bd2968f547a159207a501adead978a4cd /package/dbus
parent72da1a34648fad260fbdd73aa54e576cdb12acc2 (diff)
downloadbuildroot-novena-0cf8595f2996b46143c1a95d3bd6f4e131a94b94.tar.gz
buildroot-novena-0cf8595f2996b46143c1a95d3bd6f4e131a94b94.zip
dbus: ensure directory exists before installing symlink
If you use a custom target skeleton with no /var/lib directory, then the symlink installation in dbus.mk will fail. This patch fixes this issue by creating /var/lib before creating a symlink there. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index a855f059a..57274a0cd 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -66,6 +66,7 @@ DBUS_POST_INSTALL_TARGET_HOOKS += DBUS_REMOVE_DEVFILES
endif
define DBUS_INSTALL_TARGET_FIXUP
+ mkdir -p $(TARGET_DIR)/var/lib
rm -rf $(TARGET_DIR)/var/lib/dbus
ln -sf /tmp/dbus $(TARGET_DIR)/var/lib/dbus
$(INSTALL) -m 0755 -D package/dbus/S30dbus $(TARGET_DIR)/etc/init.d/S30dbus