summaryrefslogtreecommitdiffstats
path: root/package/dbus-glib
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /package/dbus-glib
parentf58ff9a25f24576e032c65d762e5b8fdd2cf5c1c (diff)
downloadbuildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.tar.gz
buildroot-novena-e7b38c71ce55720f7709f0049f5bfc71ca0615ec.zip
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'package/dbus-glib')
-rw-r--r--package/dbus-glib/dbus-glib.mk33
1 files changed, 17 insertions, 16 deletions
diff --git a/package/dbus-glib/dbus-glib.mk b/package/dbus-glib/dbus-glib.mk
index f0fc017cb..7cbc901cc 100644
--- a/package/dbus-glib/dbus-glib.mk
+++ b/package/dbus-glib/dbus-glib.mk
@@ -31,20 +31,20 @@ $(eval $(call AUTOTARGETS,package,dbus-glib))
DBUS_GLIB_HOST_DIR:=$(BUILD_DIR)/dbus-glib-$(DBUS_GLIB_VERSION)-host
DBUS_GLIB_HOST_BINARY:=$(HOST_DIR)/usr/bin/dbus-binding-tool
-$(DBUS_GLIB_HOST_DIR)/.unpacked: $(DL_DIR)/$(DBUS_GLIB_SOURCE)
- mkdir -p $(@D)
+$(STAMP_DIR)/host_dbusglib_unpacked: $(DL_DIR)/$(DBUS_GLIB_SOURCE)
+ mkdir -p $(DBUS_GLIB_HOST_DIR)
$(INFLATE$(suffix $(DBUS_GLIB_SOURCE))) $< | \
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(DBUS_GLIB_HOST_DIR) $(TAR_OPTIONS) -
touch $@
-$(DBUS_GLIB_HOST_DIR)/.configured: $(DBUS_GLIB_HOST_DIR)/.unpacked $(EXPAT_HOST_BINARY)
- (cd $(@D); rm -rf config.cache; \
+$(STAMP_DIR)/host_dbusglib_configured: $(STAMP_DIR)/host_dbusglib_unpacked $(STAMP_DIR)/host_dbus_installed
+ (cd $(DBUS_GLIB_HOST_DIR); rm -rf config.cache; \
$(HOST_CONFIGURE_OPTS) \
CFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)" \
- $(@D)/configure \
- --prefix=$(HOST_DIR)/usr \
- --sysconfdir=$(HOST_DIR)/etc \
+ ./configure \
+ --prefix="$(HOST_DIR)/usr" \
+ --sysconfdir="$(HOST_DIR)/etc" \
--disable-tests \
--disable-xml-docs \
--disable-bash-completion \
@@ -53,21 +53,22 @@ $(DBUS_GLIB_HOST_DIR)/.configured: $(DBUS_GLIB_HOST_DIR)/.unpacked $(EXPAT_HOST_
)
touch $@
-$(DBUS_GLIB_HOST_DIR)/.compiled: $(DBUS_GLIB_HOST_DIR)/.configured
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+$(STAMP_DIR)/host_dbusglib_compiled: $(STAMP_DIR)/host_dbusglib_configured
+ $(HOST_MAKE_ENV) $(MAKE) -C $(DBUS_GLIB_HOST_DIR)
touch $@
-$(DBUS_GLIB_HOST_BINARY): $(DBUS_GLIB_HOST_DIR)/.compiled
- $(MAKE) -C $(<D) install
+$(STAMP_DIR)/host_dbusglib_installed: $(STAMP_DIR)/host_dbusglib_compiled
+ $(HOST_MAKE_ENV) $(MAKE) -C $(DBUS_GLIB_HOST_DIR) install
+ touch $@
-host-dbus-glib: $(DBUS_GLIB_HOST_BINARY)
+host-dbus-glib: $(STAMP_DIR)/host_dbusglib_installed
host-dbus-glib-source: dbus-glib-source
host-dbus-glib-clean:
- rm -f $(addprefix $(DBUS_GLIB_HOST_DIR)/,.unpacked .configured .compiled)
- $(MAKE) -C $(DBUS_GLIB_HOST_DIR) uninstall
- $(MAKE) -C $(DBUS_GLIB_HOST_DIR) clean
+ rm -f $(addprefix $(STAMP_DIR)/host_dbusglib_,unpacked configured compiled installed)
+ -$(MAKE) -C $(DBUS_GLIB_HOST_DIR) uninstall
+ -$(MAKE) -C $(DBUS_GLIB_HOST_DIR) clean
host-dbus-glib-dirclean:
rm -rf $(DBUS_GLIB_HOST_DIR)