summaryrefslogtreecommitdiffstats
path: root/package/dash
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-22 00:22:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-22 00:22:22 +0200
commitcbcc06c3bbcd92e48f8f91cd47bc70d71594b291 (patch)
tree2f7192abdb18bdff39eea5691f6eadc417db0fbe /package/dash
parent68fe213daa83dee8f4ee54e1878c2b893e81912b (diff)
downloadbuildroot-novena-cbcc06c3bbcd92e48f8f91cd47bc70d71594b291.tar.gz
buildroot-novena-cbcc06c3bbcd92e48f8f91cd47bc70d71594b291.zip
dash: fix build of native helpers
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dash')
-rw-r--r--package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch b/package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch
new file mode 100644
index 000000000..9fd449c41
--- /dev/null
+++ b/package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch
@@ -0,0 +1,35 @@
+[PATCH] Don't include config.h when building helpers using the native compiler
+
+config.h contains settings for the cross compiler (most importantly
+32/64bit versions of functions), so don't include it when calling the
+native compiler to build the helpers.
+
+Otherwise we get build errors like:
+
+/usr/bin/gcc -include ../config.h -DBSD=1 -DSHELL -DIFS_BROKEN -g -O2 -Wall -o mkinit mkinit.c
+In file included from /usr/include/sys/stat.h:107,
+ from /usr/include/fcntl.h:38,
+ from mkinit.c:50:
+/usr/include/bits/stat.h:117: error: redefinition of ‘struct stat’
+In file included from /usr/include/fcntl.h:38,
+ from mkinit.c:50:
+/usr/include/sys/stat.h:504: error: redefinition of ‘stat’
+/usr/include/sys/stat.h:455: note: previous definition of ‘stat’ was here
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/Makefile.in | 1 -
+ 1 file changed, 1 deletion(-)
+
+Index: dash-0.5.5.1/src/Makefile.in
+===================================================================
+--- dash-0.5.5.1.orig/src/Makefile.in
++++ dash-0.5.5.1/src/Makefile.in
+@@ -165,7 +165,6 @@ COMMON_CPPFLAGS = \
+ AM_CFLAGS = $(COMMON_CFLAGS)
+ AM_CPPFLAGS = $(COMMON_CPPFLAGS)
+ AM_CFLAGS_FOR_BUILD = -g -O2 $(COMMON_CFLAGS)
+-AM_CPPFLAGS_FOR_BUILD = $(COMMON_CPPFLAGS)
+ COMPILE_FOR_BUILD = \
+ $(CC_FOR_BUILD) $(AM_CPPFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) \
+ $(AM_CFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD)