summaryrefslogtreecommitdiffstats
path: root/package/cups
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-05-01 14:00:04 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-01 14:00:04 +0200
commitbac353dbe6c4384c022f898201992ef5f5353edb (patch)
treecd6937aa71024c1281561eef5d99441b1595103b /package/cups
parent650e8e2f5cba420f546e59103286496ac62b34eb (diff)
downloadbuildroot-novena-bac353dbe6c4384c022f898201992ef5f5353edb.tar.gz
buildroot-novena-bac353dbe6c4384c022f898201992ef5f5353edb.zip
cups: cleanup cups-config handling
Includedir and rpath fixes are not needed. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cups')
-rw-r--r--package/cups/cups.mk12
1 files changed, 3 insertions, 9 deletions
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index 7f1f52eaa..b953a4b18 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -55,16 +55,10 @@ CUPS_DEPENDENCIES += host-autoconf
CUPS_PRE_CONFIGURE_HOOKS += CUPS_FIXUP_AUTOCONF
-# Fixup prefix= and exec_prefix= in cups-config, and remove the
-# -Wl,-rpath option.
+# Fixup prefix= and exec_prefix= in cups-config
define CUPS_FIXUP_CUPS_CONFIG
- $(SED) 's%prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
- $(STAGING_DIR)/usr/bin/cups-config
- $(SED) 's%exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
- $(STAGING_DIR)/usr/bin/cups-config
- $(SED) "s%includedir=.*%includedir=$(STAGING_DIR)/usr/include%" \
- $(STAGING_DIR)/usr/bin/cups-config
- $(SED) 's%-Wl,-rpath,\$${libdir}%%' \
+ $(SED) 's%^prefix=/usr%prefix=$(STAGING_DIR)/usr%' \
+ -e 's%^exec_prefix=/usr%exec_prefix=$(STAGING_DIR)/usr%' \
$(STAGING_DIR)/usr/bin/cups-config
endef