summaryrefslogtreecommitdiffstats
path: root/package/cups
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-03-06 18:06:01 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-03-06 18:06:01 +0000
commit21e0064950815d0766c1141b78c09b4a173239fb (patch)
tree567f0223f5657005884baeca5ec7ea813f1bea72 /package/cups
parent0e2ac92534e8dcceba5be8f3a44befc8b6dbb470 (diff)
downloadbuildroot-novena-21e0064950815d0766c1141b78c09b4a173239fb.tar.gz
buildroot-novena-21e0064950815d0766c1141b78c09b4a173239fb.zip
added cups
Diffstat (limited to 'package/cups')
-rw-r--r--package/cups/Config.in8
-rw-r--r--package/cups/cups-1.3.5-mantohtml.patch11
-rw-r--r--package/cups/cups-1.3.5-no-tests-man.patch13
-rw-r--r--package/cups/cups.mk32
4 files changed, 64 insertions, 0 deletions
diff --git a/package/cups/Config.in b/package/cups/Config.in
new file mode 100644
index 000000000..8179c8dae
--- /dev/null
+++ b/package/cups/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_CUPS
+ bool "cups"
+ default n
+ help
+ The Common Unix Print Subsystem
+
+ http://www.cups.org
+
diff --git a/package/cups/cups-1.3.5-mantohtml.patch b/package/cups/cups-1.3.5-mantohtml.patch
new file mode 100644
index 000000000..e6a10b0d0
--- /dev/null
+++ b/package/cups/cups-1.3.5-mantohtml.patch
@@ -0,0 +1,11 @@
+--- cups-1.3.5/man/Makefile 2007-07-12 21:01:14.000000000 -0400
++++ cups-1.3.5/man/Makefile 2008-02-11 08:55:24.000000000 -0500
+@@ -173,7 +173,7 @@ html: $(MAN1) $(MAN5) $(MAN7) $(MAN8) ma
+ done
+
+ mantohtml: mantohtml.o
+- $(CC) $(LDFLAGS) -o $@ mantohtml.o
++ gcc -I/usr/include -I../ -L/usr/lib mantohtml.c -o mantohtml
+
+
+ #
diff --git a/package/cups/cups-1.3.5-no-tests-man.patch b/package/cups/cups-1.3.5-no-tests-man.patch
new file mode 100644
index 000000000..567c801c6
--- /dev/null
+++ b/package/cups/cups-1.3.5-no-tests-man.patch
@@ -0,0 +1,13 @@
+--- cups-1.3.5/Makefile 2007-12-06 15:09:39.000000000 -0500
++++ cups-1.3.5/Makefile 2008-02-09 21:53:03.000000000 -0500
+@@ -19,8 +19,8 @@ include Makedefs
+ # Directories to make...
+ #
+
+-DIRS = cups backend berkeley cgi-bin filter locale man monitor \
+- notifier $(PDFTOPS) scheduler systemv test \
++DIRS = cups backend berkeley cgi-bin filter locale monitor \
++ notifier $(PDFTOPS) scheduler systemv \
+ $(PHPDIR) \
+ conf data doc $(FONTS) ppd templates
+
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
new file mode 100644
index 000000000..2367acaa1
--- /dev/null
+++ b/package/cups/cups.mk
@@ -0,0 +1,32 @@
+################################################################################
+#
+# cups
+#
+################################################################################
+
+CUPS_VERSION = 1.3.5
+CUPS_SOURCE = cups-$(CUPS_VERSION)-source.tar.bz2
+CUPS_SITE = http://ftp.easysw.com/pub/cups/1.3.5
+CUPS_AUTORECONF = NO
+CUPS_INSTALL_STAGING = YES
+CUPS_INSTALL_TARGET = YES
+CUPS_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install DSTROOT=$(STAGING_DIR)
+CUPS_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install DSTROOT=$(TARGET_DIR)
+
+ifeq ($(BR2_PACKAGE_DBUS),y)
+ CUPS_CONF_OPT_DBUS =--disable-dbus
+ CUPS_DEPENDENCIES_DBUS = dbus
+else
+ CUPS_CONF_OPT_DBUS =--enable-dbus
+endif
+
+ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ CUPS_DEPENDENCIES_X = xlib_libX11
+endif
+
+CUPS_CONF_OPT = --prefix=/usr --includedir=/usr/include --libdir=/usr/lib --disable-gnutls --disable-gssapi $(CUPS_CONF_OPT_DBUS)
+CUPS_MAKE_OPT = cups backend berkeley cgi-bin filter locale monitor notifier pdftops scheduler systemv scripting/php conf data doc fonts ppd templates
+
+CUPS_DEPENDENCIES = $(CUPS_DEPENDENCIES_DBUS) $(CUPS_DEPENDENCIES_X)
+
+$(eval $(call AUTOTARGETS,package,cups))