summaryrefslogtreecommitdiffstats
path: root/package/cryptodev
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-04-27 10:09:46 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-05 22:59:47 +0200
commit6235f6822274fa1d7989de258587074b101cdafe (patch)
treed6f9419d522e9ca96920b5ca2359d49e9c9b2ac4 /package/cryptodev
parent1c2d3183e2e75bd21bc4b7377e76be74ce6e1432 (diff)
downloadbuildroot-novena-6235f6822274fa1d7989de258587074b101cdafe.tar.gz
buildroot-novena-6235f6822274fa1d7989de258587074b101cdafe.zip
cryptodev: add new virtual
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cryptodev')
-rw-r--r--package/cryptodev/Config.in37
-rw-r--r--package/cryptodev/cryptodev.mk24
2 files changed, 61 insertions, 0 deletions
diff --git a/package/cryptodev/Config.in b/package/cryptodev/Config.in
new file mode 100644
index 000000000..3f08e9e81
--- /dev/null
+++ b/package/cryptodev/Config.in
@@ -0,0 +1,37 @@
+config BR2_PACKAGE_CRYPTODEV
+ bool "cryptodev support"
+ depends on BR2_LINUX_KERNEL
+ help
+ Select the desired cryptodev implementation.
+
+if BR2_PACKAGE_CRYPTODEV
+
+choice
+ prompt "cryptodev variant"
+ default BR2_PACKAGE_CRYPTODEV_LINUX if !BR2_microblaze
+ help
+ Select the cryptodev implementation.
+
+config BR2_PACKAGE_CRYPTODEV_LINUX
+ bool "cryptodev-linux"
+ depends on !BR2_microblaze
+ help
+ Cryptodev-linux is a device that allows access to Linux kernel
+ cryptographic drivers; thus allowing userspace applications
+ to take advantage of hardware accelerators.
+
+ http://cryptodev-linux.org/index.html
+
+config BR2_PACKAGE_OCF_LINUX
+ bool "ocf-linux"
+ help
+ OCF-Linux is a Linux port of the OpenBSD/FreeBSD Cryptographic
+ Framework (OCF). This port aims to bring full asynchronous HW/SW
+ crypto acceleration to the Linux kernel and applications
+ running under Linux.
+
+ http://ocf-linux.sourceforge.net/
+
+endchoice
+
+endif
diff --git a/package/cryptodev/cryptodev.mk b/package/cryptodev/cryptodev.mk
new file mode 100644
index 000000000..b6f4a42d1
--- /dev/null
+++ b/package/cryptodev/cryptodev.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# Virtual cryptodev package
+#
+#############################################################
+
+CRYPTODEV_SOURCE =
+
+ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
+CRYPTODEV_DEPENDENCIES += cryptodev-linux
+endif
+
+ifeq ($(BR2_PACKAGE_OCF_LINUX),y)
+CRYPTODEV_DEPENDENCIES += ocf-linux
+endif
+
+ifeq ($(CRYPTODEV_DEPENDENCIES),)
+define CRYPTODEV_CONFIGURE_CMDS
+ echo "No CRYPTODEV implementation defined. Configuration error"
+ exit 1
+endef
+endif
+
+$(eval $(generic-package))