summaryrefslogtreecommitdiffstats
path: root/package/coreutils
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-17 12:30:31 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-17 12:30:31 +0000
commite4c6340a949f64e6fc0294a1e41cf05dbaa82df9 (patch)
tree12a7f94b8461feec5eb1ad87481ddb06eb6834f8 /package/coreutils
parentb14ff970126831720990961f0a7e2fd5f019365d (diff)
downloadbuildroot-novena-e4c6340a949f64e6fc0294a1e41cf05dbaa82df9.tar.gz
buildroot-novena-e4c6340a949f64e6fc0294a1e41cf05dbaa82df9.zip
- cleanup and fixes (Cristian Ionescu-Idbohrn)
Diffstat (limited to 'package/coreutils')
-rw-r--r--package/coreutils/coreutils.mk20
1 files changed, 14 insertions, 6 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index 43de029e2..468a54a34 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -95,8 +95,8 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--disable-rpath \
@@ -119,17 +119,25 @@ $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY): $(COREUTILS_DIR)/$(COREUTILS_BINARY)
# gnu thinks chroot is in bin, debian thinks it's in sbin
mv $(TARGET_DIR)/usr/bin/chroot $(TARGET_DIR)/usr/sbin/chroot
$(STRIP) $(TARGET_DIR)/usr/sbin/chroot > /dev/null 2>&1
- rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
- $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+ifneq ($(BR2_HAVE_INFOPAGES),y)
+ rm -rf $(TARGET_DIR)/usr/share/info
+endif
+ifneq ($(BR2_HAVE_MANPAGES),y)
+ rm -rf $(TARGET_DIR)/usr/share/man
+endif
+ rm -rf $(TARGET_DIR)/share/locale
+ rm -rf $(TARGET_DIR)/usr/share/doc
-#If both coreutils and busybox are selected, make certain coreutils
-#wins the fight over who gets to have their utils actually installed
+# If both coreutils and busybox are selected, make certain coreutils
+# wins the fight over who gets to have their utils actually installed.
ifeq ($(BR2_PACKAGE_BUSYBOX),y)
coreutils: uclibc busybox $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
else
coreutils: uclibc $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
endif
+# If both coreutils and busybox are selected, the corresponding applets
+# may need to be reinstated by the clean targets.
coreutils-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) uninstall
-$(MAKE) -C $(COREUTILS_DIR) clean