summaryrefslogtreecommitdiffstats
path: root/package/coreutils
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-06 09:27:32 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-07 08:20:21 +0200
commita1c8fa41f6f6e5047182fe90656bcd30243bca8d (patch)
treecf1b67669365d0aabc1756fa5ffab71cbeaea571 /package/coreutils
parent08235f7144d08bc111b07d3523ac6439f6fd0b94 (diff)
downloadbuildroot-novena-a1c8fa41f6f6e5047182fe90656bcd30243bca8d.tar.gz
buildroot-novena-a1c8fa41f6f6e5047182fe90656bcd30243bca8d.zip
Update all packages to quote $(TARGET_CC)
Now that TARGET_CC contains several space-separated words, it must be used quoted everywhere. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/coreutils')
-rw-r--r--package/coreutils/coreutils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index e2f7bc5e9..f9910c66a 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -109,7 +109,7 @@ $(COREUTILS_DIR)/$(COREUTILS_BINARY): $(COREUTILS_DIR)/.configured
rm -f $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
$(TARGET_DIR)/$(COREUTILS_TARGET_BINARY): $(COREUTILS_DIR)/$(COREUTILS_BINARY)
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) install
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC="$(TARGET_CC)" -C $(COREUTILS_DIR) install
# some things go in root rather than usr
for f in $(BIN_PROGS); do \
mv $(TARGET_DIR)/usr/bin/$$f $(TARGET_DIR)/bin/$$f; \
@@ -132,7 +132,7 @@ endif
# If both coreutils and busybox are selected, the corresponding applets
# may need to be reinstated by the clean targets.
coreutils-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) uninstall
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC="$(TARGET_CC)" -C $(COREUTILS_DIR) uninstall
-$(MAKE) -C $(COREUTILS_DIR) clean
coreutils-dirclean: