summaryrefslogtreecommitdiffstats
path: root/package/cmake
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-25 11:41:56 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-07 08:14:02 +0200
commit77b5b803c7ae4298b885d6b2e0b7506804943669 (patch)
tree14395ecf3b1249f11c30dc702d7c13619480880d /package/cmake
parent8bd423159927d40647e47681a74e483fef178677 (diff)
downloadbuildroot-novena-77b5b803c7ae4298b885d6b2e0b7506804943669.tar.gz
buildroot-novena-77b5b803c7ae4298b885d6b2e0b7506804943669.zip
cmake: pass LDFLAGS/CFLAGS when building for the host
Passing LDFLAGS/CFLAGS when building for the host allows cmake to be compiled with the proper -rpath value (the -rpath option is added to HOST_LDFLAGS in a later commit). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cmake')
-rw-r--r--package/cmake/cmake.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/cmake/cmake.mk b/package/cmake/cmake.mk
index 42d4ff5ed..b388874ae 100644
--- a/package/cmake/cmake.mk
+++ b/package/cmake/cmake.mk
@@ -4,7 +4,9 @@ CMAKE_SITE=http://www.cmake.org/files/v2.8/
define HOST_CMAKE_CONFIGURE_CMDS
(cd $(@D); \
- ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
+ LDFLAGS="$(HOST_LDFLAGS)" \
+ CFLAGS="$(HOST_CFLAGS)" \
+ ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
)
endef