summaryrefslogtreecommitdiffstats
path: root/package/cloop
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-02 22:35:44 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:03:55 +0200
commitae4c8a81d3ef9736998d157e9e989acab17e9cb2 (patch)
tree23f1c1ff4296e622c665b25dd17f9e9b1b86ebe9 /package/cloop
parentde4cf4e9135e198d4c3beefc8ad63c03870eb78a (diff)
downloadbuildroot-novena-ae4c8a81d3ef9736998d157e9e989acab17e9cb2.tar.gz
buildroot-novena-ae4c8a81d3ef9736998d157e9e989acab17e9cb2.zip
cloop: new package
Only the host variant is supported, which explains why there is no Config.in file. Will be used by the filesystem generation code. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cloop')
-rw-r--r--package/cloop/cloop.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
new file mode 100644
index 000000000..f1c1e1c4e
--- /dev/null
+++ b/package/cloop/cloop.mk
@@ -0,0 +1,18 @@
+CLOOP_VERSION=2.631-1
+CLOOP_SOURCE=cloop_$(CLOOP_VERSION).tar.gz
+CLOOP_SITE=http://debian-knoppix.alioth.debian.org/sources/
+
+HOST_CLOOP_DEPENDENCIES = host-zlib
+
+define HOST_CLOOP_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE1) \
+ CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_ERROR_SILENT" -C $(@D) APPSONLY=yes
+endef
+
+define HOST_CLOOP_INSTALL_CMDS
+ install -m 755 $(@D)/create_compressed_fs $(HOST_DIR)/usr/bin
+ install -m 755 $(@D)/extract_compressed_fs $(HOST_DIR)/usr/bin
+endef
+
+$(eval $(call GENTARGETS,package,cloop))
+$(eval $(call GENTARGETS,package,cloop,host)) \ No newline at end of file