summaryrefslogtreecommitdiffstats
path: root/package/cloop
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-16 10:47:34 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-28 20:13:05 +0100
commit467f221d20f2a1927ef695bd4ac92559257ce8f9 (patch)
treeb35ba2b00b5dc4a3252868e7376651dfe2a86711 /package/cloop
parent6527001c9d42b95c76b7689ed8eeecd8d17740cd (diff)
downloadbuildroot-novena-467f221d20f2a1927ef695bd4ac92559257ce8f9.tar.gz
buildroot-novena-467f221d20f2a1927ef695bd4ac92559257ce8f9.zip
cloop: bump and fix package
On a machine without zlib-dev installed, cloop must rely on the host-zlib compiled by Buildroot, but due to the horrible cloop build system, this didn't happen and the build was failing. Therefore, we now pass all the $(HOST_CONFIGURE_OPTS) when building cloop, and we fix the Makefile so that it takes into account CFLAGS/LDFLAGS passed in the environment or command-line and do not override them. [Peter: fix typos, remove HOST_MAKE_ENV] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cloop')
-rw-r--r--package/cloop/cloop-2.634-1-cflags.patch30
-rw-r--r--package/cloop/cloop.mk5
2 files changed, 32 insertions, 3 deletions
diff --git a/package/cloop/cloop-2.634-1-cflags.patch b/package/cloop/cloop-2.634-1-cflags.patch
new file mode 100644
index 000000000..c421dd7f8
--- /dev/null
+++ b/package/cloop/cloop-2.634-1-cflags.patch
@@ -0,0 +1,30 @@
+Take into account the CFLAGS/LDFLAGS passed in the environment.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: host-cloop-2.634-1/Makefile
+===================================================================
+--- host-cloop-2.634-1.orig/Makefile 2010-12-16 09:17:52.826555645 +0100
++++ host-cloop-2.634-1/Makefile 2010-12-16 09:18:57.208713338 +0100
+@@ -15,7 +15,7 @@
+ endif
+
+ ifdef APPSONLY
+-CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
++CLOOP_CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
+ endif
+
+ KERNOBJ:=compressed_loop.o
+@@ -53,10 +53,10 @@
+ ( cd advancecomp-1.15 ; ./configure && $(MAKE) advfs )
+
+ extract_compressed_fs: extract_compressed_fs.c
+- $(CC) -Wall -O2 -s -o $@ $< -lz
++ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -Wall -O2 -s -o $@ $< -lz
+
+ cloop_suspend: cloop_suspend.o
+- $(CC) -o $@ $<
++ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -o $@ $<
+
+ clean:
+ rm -rf create_compressed_fs extract_compressed_fs zoom *.o *.ko Module.symvers .cloop* .compressed_loop.* .tmp*
diff --git a/package/cloop/cloop.mk b/package/cloop/cloop.mk
index 4c160986c..fa47a5f5f 100644
--- a/package/cloop/cloop.mk
+++ b/package/cloop/cloop.mk
@@ -1,12 +1,11 @@
-CLOOP_VERSION=2.631-1
+CLOOP_VERSION=2.634-1
CLOOP_SOURCE=cloop_$(CLOOP_VERSION).tar.gz
CLOOP_SITE=http://debian-knoppix.alioth.debian.org/packages/sources/cloop
HOST_CLOOP_DEPENDENCIES = host-zlib
define HOST_CLOOP_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE1) \
- CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_ERROR_SILENT" -C $(@D) APPSONLY=yes
+ $(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D) APPSONLY=yes
endef
define HOST_CLOOP_INSTALL_CMDS