summaryrefslogtreecommitdiffstats
path: root/package/classpath
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-04 09:59:09 -0800
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-04 10:21:05 -0800
commit5062f530081913bd0487f0f879be180f30836ab8 (patch)
tree6ae7a28f9cea3792efe6fae74a67da261dd95636 /package/classpath
parentcceda0efeaaa73af490940a628dbd175db3aa277 (diff)
downloadbuildroot-novena-5062f530081913bd0487f0f879be180f30836ab8.tar.gz
buildroot-novena-5062f530081913bd0487f0f879be180f30836ab8.zip
package: add classpath
Requires java, javac and jar on the build machine, similar to how we require gcc/g++. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk> classpath: fixup
Diffstat (limited to 'package/classpath')
-rw-r--r--package/classpath/Config.in14
-rw-r--r--package/classpath/classpath.mk55
2 files changed, 69 insertions, 0 deletions
diff --git a/package/classpath/Config.in b/package/classpath/Config.in
new file mode 100644
index 000000000..45d598498
--- /dev/null
+++ b/package/classpath/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_CLASSPATH
+ bool "classpath"
+ depends on BR2_PACKAGE_JAMVM
+ depends on BR2_INET_IPV6
+ help
+ GNU Classpath, Essential Libraries for Java, is a GNU
+ project to create free core class libraries for use with
+ virtual machines and compilers for the java programming
+ language.
+
+ http://classpath.org
+
+comment "classpath requires a toolchain with IPV6 support"
+ depends on !BR2_INET_IPV6
diff --git a/package/classpath/classpath.mk b/package/classpath/classpath.mk
new file mode 100644
index 000000000..9142f6915
--- /dev/null
+++ b/package/classpath/classpath.mk
@@ -0,0 +1,55 @@
+CLASSPATH_VERSION = 0.98
+CLASSPATH_SITE = $(BR2_GNU_MIRROR)/classpath
+CLASSPATH_CONF_OPT = \
+ --disable-examples \
+ --disable-plugin \
+ --disable-rpath \
+ --disable-Werror \
+ --disable-gconf-peer \
+ --disable-tools
+
+CLASSPATH_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+CLASSPATH_CONF_OPT += --enable-alsa
+CLASSPATH_DEPENDENCIES += alsa-lib
+else
+CLASSPATH_CONF_OPT += --disable-alsa
+endif
+
+ifeq ($(BR2_PACKAGE_GMP),y)
+CLASSPATH_CONF_OPT += --enable-gmp
+CLASSPATH_DEPENDENCIES += gmp
+else
+CLASSPATH_CONF_OPT += --disable-gmp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
+CLASSPATH_CONF_OPT += --enable-gstreamer-peer
+CLASSPATH_DEPENDENCIES += gst-plugins-base
+else
+CLASSPATH_CONF_OPT += --disable-gstreamer-peer
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG7),yy)
+CLASSPATH_CONF_OPT += --enable-gtk-peer
+CLASSPATH_DEPENDENCIES += libgtk2
+else
+CLASSPATH_CONF_OPT += --disable-gtk-peer
+endif
+
+ifeq ($(BR2_PACKAGE_QT),y)
+CLASSPATH_CONF_OPT += --enable-qt-peer
+CLASSPATH_DEPENDENCIES += qt
+else
+CLASSPATH_CONF_OPT += --disable-qt-peer
+endif
+
+ifeq ($(BR2_PACKAGE_LIBXML2)$(BR2_PACKAGE_LIBXSLT),yy)
+CLASSPATH_CONF_OPT += --enable-xmlj
+CLASSPATH_DEPENDENCIES += libxml2 libxslt
+else
+CLASSPATH_CONF_OPT += --disable-xmlj
+endif
+
+$(eval $(autotools-package))