summaryrefslogtreecommitdiffstats
path: root/package/cjson
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2012-08-27 15:58:06 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-06 22:55:08 +0200
commitd6743630d25e3e8f483ead766224444ff24965b5 (patch)
tree5f8bc96e925b5d15595ba7c547c87079523521fc /package/cjson
parent8e4d40751ed22f9a36ec541686456075b0808d59 (diff)
downloadbuildroot-novena-d6743630d25e3e8f483ead766224444ff24965b5.tar.gz
buildroot-novena-d6743630d25e3e8f483ead766224444ff24965b5.zip
cjson: bug fix - use -fPIC instead of -fpic
This change is to fix the autobuild failure at: http://autobuild.buildroot.net/results/45e2c08d5e3c868b2d7fdf26a7c5f88de5ff8f61/build-end.log I can't actually reproduce this bug, because my machine cannot run the 64-bit microblaze toolchain. However, the log makes it clear that -fPIC is needed, and grepping for fPIC and fpic under packages makes it clear that cjson should have used -fPIC anyway. So even if the bug isn't fixed, it must surely be improved. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cjson')
-rw-r--r--package/cjson/cjson.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/cjson/cjson.mk b/package/cjson/cjson.mk
index 79b4c3118..dd6401074 100644
--- a/package/cjson/cjson.mk
+++ b/package/cjson/cjson.mk
@@ -14,7 +14,7 @@ define CJSON_EXTRACT_CMDS
endef
define CJSON_BUILD_CMDS
- cd $(@D)/cJSON && $(TARGET_CC) $(TARGET_CFLAGS) -shared -fpic cJSON.c -o libcJSON.so
+ cd $(@D)/cJSON && $(TARGET_CC) $(TARGET_CFLAGS) -shared -fPIC cJSON.c -o libcJSON.so
endef
define CJSON_INSTALL_STAGING_CMDS