summaryrefslogtreecommitdiffstats
path: root/package/celt051
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-16 06:56:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 20:35:18 +0100
commita13fd5f4ceba61570cbfb22c452ee8abb898414e (patch)
tree11b9aa3fbfadfa8af63303705ed97688ebd78423 /package/celt051
parentda1147e763737f5dd4da3d20c5bf2109d5d85562 (diff)
downloadbuildroot-novena-a13fd5f4ceba61570cbfb22c452ee8abb898414e.tar.gz
buildroot-novena-a13fd5f4ceba61570cbfb22c452ee8abb898414e.zip
package/celt051: new package
[Peter: move to Libraries->Audio/Sound] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/celt051')
-rw-r--r--package/celt051/Config.in15
-rw-r--r--package/celt051/celt.mk30
2 files changed, 45 insertions, 0 deletions
diff --git a/package/celt051/Config.in b/package/celt051/Config.in
new file mode 100644
index 000000000..50ed06927
--- /dev/null
+++ b/package/celt051/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_CELT051
+ bool "celt051"
+ select BR2_PACKAGE_LIBOGG
+ help
+ The CELT ultra-low delay audio codec
+
+ The CELT codec is a compression algorithm for audio. Like MP3,
+ Vorbis, and AAC it is suitable for transmitting music with high
+ quality. Unlike these formats CELT imposes very little delay on
+ the signal, even less than is typical for speech centric formats
+ like Speex, GSM, or G.729.
+
+ Note: this is version 0.5.1.3 of celt.
+
+ http://www.celt-codec.org/
diff --git a/package/celt051/celt.mk b/package/celt051/celt.mk
new file mode 100644
index 000000000..9baaa8245
--- /dev/null
+++ b/package/celt051/celt.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# celt051
+#
+#############################################################
+
+# Although version newer than 0.5.1.3 exists, we're
+# stuck with 0.5.1.3 for use by Spice (coming later)
+CELT051_VERSION = 0.5.1.3
+CELT051_SOURCE = celt-$(CELT051_VERSION).tar.gz
+CELT051_SITE = http://downloads.xiph.org/releases/celt
+CELT051_LICENSE = BSD-2c
+CELT051_LICENSE_FILES = COPYING
+CELT051_INSTALL_STAGING = YES
+CELT051_DEPENDENCIES = libogg
+
+# Need to specify --with-ogg, otherwise /usr/lib may be searched for
+# if target is the same kind as host (ie. same arch, same bitness,
+# same endianness, so that /usr/lib contains libraries linkable by
+# our cross-compiler)
+CELT051_CONF_OPT = \
+ --enable-fixed-point \
+ --disable-fixed-point-debug \
+ --disable-experimental-postfilter \
+ --disable-static-modes \
+ --disable-assertions \
+ --disable-oggtest \
+ --with-ogg=$(STAGING_DIR)/usr \
+
+$(eval $(autotools-package))