summaryrefslogtreecommitdiffstats
path: root/package/cegui06/cegui06.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-16 06:56:12 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 21:00:56 +0100
commit303c922c62d2eb08ce3ffb02206b9bf959b305dc (patch)
treec3648b5da99dc0b9c0fab158811690a89b17cd52 /package/cegui06/cegui06.mk
parentdf07240d6fb4c60ecc65a54ea10dfc729773a803 (diff)
downloadbuildroot-novena-303c922c62d2eb08ce3ffb02206b9bf959b305dc.tar.gz
buildroot-novena-303c922c62d2eb08ce3ffb02206b9bf959b305dc.zip
package/cegui06: new package
Although there are more recent versions of CEGUI, we are stuck with 0.6.2b for use by spice. [Peter: add C++ dependency] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cegui06/cegui06.mk')
-rw-r--r--package/cegui06/cegui06.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/cegui06/cegui06.mk b/package/cegui06/cegui06.mk
new file mode 100644
index 000000000..817254f44
--- /dev/null
+++ b/package/cegui06/cegui06.mk
@@ -0,0 +1,36 @@
+#############################################################
+#
+# libcegui
+#
+#############################################################
+
+# Do not update the version, we need exactly that one for Spice.
+CEGUI06_VERSION_MAJOR = 0.6.2
+CEGUI06_VERSION = $(CEGUI06_VERSION_MAJOR)b
+CEGUI06_SOURCE = CEGUI-$(CEGUI06_VERSION).tar.gz
+CEGUI06_SITE = http://downloads.sourceforge.net/project/crayzedsgui/CEGUI%20Mk-2/$(CEGUI06_VERSION_MAJOR)
+CEGUI06_LICENSE = MIT
+CEGUI06_LICENSE_FILES = COPYING
+CEGUI06_INSTALL_STAGING = YES
+
+CEGUI06_DEPENDENCIES = \
+ expat \
+ freetype \
+ pcre \
+
+CEGUI06_CONF_OPT = \
+ --enable-expat \
+ --disable-external-tinyxml \
+ --disable-xerces-c \
+ --disable-libxml \
+ --disable-tinyxml \
+ --disable-opengl-renderer \
+ --disable-external-glew \
+ --disable-irrlicht-renderer \
+ --disable-directfb-renderer \
+ --disable-samples \
+ --disable-lua-module \
+ --disable-toluacegui \
+ --disable-external-toluapp \
+
+$(eval $(autotools-package))