summaryrefslogtreecommitdiffstats
path: root/package/cairo
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/cairo
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
downloadbuildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.tar.gz
buildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.zip
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/cairo')
-rw-r--r--package/cairo/Config.in1
-rw-r--r--package/cairo/cairo.mk2
2 files changed, 1 insertions, 2 deletions
diff --git a/package/cairo/Config.in b/package/cairo/Config.in
index bd2845b3c..e19efb5c4 100644
--- a/package/cairo/Config.in
+++ b/package/cairo/Config.in
@@ -1,6 +1,5 @@
config BR2_PACKAGE_CAIRO
bool "cairo"
- select BR2_PACKAGE_PKGCONFIG
select BR2_PACKAGE_PIXMAN
select BR2_PACKAGE_FONTCONFIG
help
diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index 668f915c6..c1f80d7b1 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -40,7 +40,7 @@ CAIRO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
ac_cv_func_working_mktime=yes jm_cv_func_working_re_compile_pattern=yes \
ac_use_included_regex=no gl_cv_c_restrict=no
-CAIRO_DEPENDENCIES = uclibc pkgconfig fontconfig pixman
+CAIRO_DEPENDENCIES = uclibc host-pkgconfig fontconfig pixman
ifeq ($(BR2_PACKAGE_DIRECTFB),y)
CAIRO_CONF_OPT += --enable-directfb