summaryrefslogtreecommitdiffstats
path: root/package/cairo
diff options
context:
space:
mode:
authorStefan Froberg <stefan.froberg@petroprogram.com>2012-08-12 00:57:11 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-12 18:29:45 +0200
commit42136fea75b123377df99189fc8c8871cd568584 (patch)
treed665e5017c51b87348a9a66899383f14266c57c5 /package/cairo
parent77d3c5d457784d5035d7fece1c3ee0ef5cd46d92 (diff)
downloadbuildroot-novena-42136fea75b123377df99189fc8c8871cd568584.tar.gz
buildroot-novena-42136fea75b123377df99189fc8c8871cd568584.zip
cairo: Add tee surface backend option (required by firefox)
Signed-off-by: Stefan Froberg <stefan.froberg@petroprogram.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cairo')
-rw-r--r--package/cairo/Config.in3
-rw-r--r--package/cairo/cairo.mk6
2 files changed, 9 insertions, 0 deletions
diff --git a/package/cairo/Config.in b/package/cairo/Config.in
index 19c47231d..398e47fb6 100644
--- a/package/cairo/Config.in
+++ b/package/cairo/Config.in
@@ -32,4 +32,7 @@ config BR2_PACKAGE_CAIRO_SVG
select BR2_PACKAGE_CAIRO_PNG
select BR2_PACKAGE_CAIRO_PDF
+config BR2_PACKAGE_CAIRO_TEE
+ bool "tee support"
endif
+
diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index 6b456dd89..eedb28d0e 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -77,4 +77,10 @@ else
CAIRO_CONF_OPT += --disable-svg
endif
+ifeq ($(BR2_PACKAGE_CAIRO_TEE),y)
+ CAIRO_CONF_OPT += --enable-tee
+else
+ CAIRO_CONF_OPT += --disable-tee
+endif
+
$(eval $(autotools-package))