summaryrefslogtreecommitdiffstats
path: root/package/bzip2
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-07 23:34:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-07 23:37:33 +0200
commit3917ab310490cb50cdb87c95e2461747069aa8a6 (patch)
treeb7e837be1175ed6b83879558f2bffaf5ab824b09 /package/bzip2
parent3b709a3d86407556f09642ef5ee4b37de2f4e93c (diff)
downloadbuildroot-novena-3917ab310490cb50cdb87c95e2461747069aa8a6.tar.gz
buildroot-novena-3917ab310490cb50cdb87c95e2461747069aa8a6.zip
bzip2: don't overwrite busybox during installation
The bzip2 make install target follows symlinks, so if busybox is enabled and the bzip/bunzip2 applets are installed, bin/busybox will get overwritten by bzip2. Fix it by ensuring any previously installed bzip2/bunzip2/bzcat (the applets available in busybox) are removed before running make install. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bzip2')
-rw-r--r--package/bzip2/bzip2.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/bzip2/bzip2.mk b/package/bzip2/bzip2.mk
index 39e183205..3f341ee7a 100644
--- a/package/bzip2/bzip2.mk
+++ b/package/bzip2/bzip2.mk
@@ -49,7 +49,9 @@ define BZIP2_INSTALL_STAGING_CMDS
)
endef
+# make sure busybox doesn't get overwritten by make install
define BZIP2_INSTALL_TARGET_CMDS
+ rm -f $(addprefix $(TARGET_DIR)/usr/bin/,bzip2 bunzip2 bzcat)
$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \
$(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(@D) install
cp $(@D)/libbz2.so.$(BZIP2_SONAME) $(TARGET_DIR)/usr/lib/