summaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2012-01-11 18:53:39 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-01 23:04:49 +0100
commitc7746857d102e69e54202763eeb785a45755845d (patch)
tree388591498a08bedae1402429596ae64ec3fa2485 /package/busybox
parent2444085bdc3b2931c4826e455b938ce75d10821c (diff)
downloadbuildroot-novena-c7746857d102e69e54202763eeb785a45755845d.tar.gz
buildroot-novena-c7746857d102e69e54202763eeb785a45755845d.zip
Convert busybox to the device declaration method
Busybox used to declare and create files even if the package was not enabled through the device table. Remove the entries for busybox in the device table and move them to the package declaration. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/busybox.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index d18b6d0b1..59448d5a2 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -28,6 +28,11 @@ ifndef BUSYBOX_CONFIG_FILE
BUSYBOX_CONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG))
endif
+define BUSYBOX_PERMISSIONS
+/bin/busybox f 4755 0 0 - - - - -
+/usr/share/udhcpc/default.script f 755 0 0 - - - - -
+endef
+
# If mdev will be used for device creation enable it and copy S10mdev to /etc/init.d
ifeq ($(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),y)
define BUSYBOX_INSTALL_MDEV_SCRIPT