summaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2013-02-18 00:38:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-18 22:30:42 +0100
commit34945ebbd00c19f534d7d11d62bd03da2b3c4425 (patch)
tree276a60faf4c277b6d8c395b107b6a29b8a3b01a2 /package/busybox
parent4b6f552a070b378fb12b07756f1df35db745598b (diff)
downloadbuildroot-novena-34945ebbd00c19f534d7d11d62bd03da2b3c4425.tar.gz
buildroot-novena-34945ebbd00c19f534d7d11d62bd03da2b3c4425.zip
busybox: support millisecond watchdog periods
The BusyBox watchdog application supports reset periods specified in milliseconds. The Buildroot package will only allow an integer reset period, which prevents the use of the required "ms" suffix. Change the watchdog period configuration item to a string, to allow the use of the "ms" suffix. Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Config.in4
-rw-r--r--package/busybox/busybox.mk2
2 files changed, 4 insertions, 2 deletions
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 2890c492d..4d9899dbf 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -64,12 +64,14 @@ config BR2_PACKAGE_BUSYBOX_WATCHDOG
if BR2_PACKAGE_BUSYBOX_WATCHDOG
config BR2_PACKAGE_BUSYBOX_WATCHDOG_PERIOD
- int "Delay between reset"
+ string "Delay between reset"
default "5"
help
Select the number of seconds between each
reset of the watchdog (default 5)
+ Use ms suffix to specify milliseconds (e.g. 500ms)
+
endif
endif
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 599e14553..900896f70 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -168,7 +168,7 @@ define BUSYBOX_INSTALL_WATCHDOG_SCRIPT
[ -f $(TARGET_DIR)/etc/init.d/S15watchdog ] || \
install -D -m 0755 package/busybox/S15watchdog \
$(TARGET_DIR)/etc/init.d/S15watchdog && \
- sed -i s/PERIOD/$(BR2_PACKAGE_BUSYBOX_WATCHDOG_PERIOD)/ \
+ sed -i s/PERIOD/$(call qstrip,$(BR2_PACKAGE_BUSYBOX_WATCHDOG_PERIOD))/ \
$(TARGET_DIR)/etc/init.d/S15watchdog
endef
endif