summaryrefslogtreecommitdiffstats
path: root/package/busybox/busybox.mk
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-10 09:28:40 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-11 10:50:13 +0100
commitca2b65a6515800991dae49d1815b7bb933f4015c (patch)
tree49afc2fbc535fdf5551ce5f7c0bccdd9ff7112aa /package/busybox/busybox.mk
parent69df644f5c539760cc4fd425571ee9d6dc4295b3 (diff)
downloadbuildroot-novena-ca2b65a6515800991dae49d1815b7bb933f4015c.tar.gz
buildroot-novena-ca2b65a6515800991dae49d1815b7bb933f4015c.zip
busybox: let buildroot handle stripping
For some ABI's (like FLAT), we cannot strip busybox as the file format does not support it and strip will abort with errors like 'File format not recognized'. Since the toplevel already takes care of stripping things, simply disable the busybox step. Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/busybox/busybox.mk')
-rw-r--r--package/busybox/busybox.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 342819a8f..38897f797 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -21,7 +21,8 @@ BUSYBOX_MAKE_OPTS = \
PREFIX="$(TARGET_DIR)" \
EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- CONFIG_PREFIX="$(TARGET_DIR)"
+ CONFIG_PREFIX="$(TARGET_DIR)" \
+ SKIP_STRIP=y
ifndef BUSYBOX_CONFIG_FILE
BUSYBOX_CONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG))