summaryrefslogtreecommitdiffstats
path: root/package/busybox/busybox.mk
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2010-12-09 10:55:05 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-13 00:29:23 +0100
commit274e34af3b7ce1d8be8de52799d15e43456b30b5 (patch)
treecb739fb8e7c4e1511abf693cb31c83e360b34b2a /package/busybox/busybox.mk
parentcd182cae65c0075c16910dc6b990fc3f8abbd776 (diff)
downloadbuildroot-novena-274e34af3b7ce1d8be8de52799d15e43456b30b5.tar.gz
buildroot-novena-274e34af3b7ce1d8be8de52799d15e43456b30b5.zip
busybox: move udhcp script from skeleton to package
Since udhcpc is part of busybox, it seems logical to move the udhcpc script from skeleton to busybox. [Peter: only install if not available in skeleton] Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/busybox/busybox.mk')
-rw-r--r--package/busybox/busybox.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index b7f474091..1010df38d 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -141,7 +141,10 @@ endif
define BUSYBOX_INSTALL_TARGET_CMDS
$(BUSYBOX_INSTALL_BINARY)
- -chmod a+rx $(TARGET_DIR)/usr/share/udhcpc/default.script
+ if [ ! -f $(TARGET_DIR)/usr/share/udhcpc/default.script ]; then \
+ $(INSTALL) -m 0755 -D package/busybox/udhcpc.script \
+ $(TARGET_DIR)/usr/share/udhcpc/default.script; \
+ fi
endef
define BUSYBOX_UNINSTALL_TARGET_CMDS