summaryrefslogtreecommitdiffstats
path: root/package/bridge-utils
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 23:11:21 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:26:50 +0200
commit9785f71c7a7a0eebf496d45e516b83c8019f6468 (patch)
tree56f630b35415e9f6e2ff977f0e7194151149e038 /package/bridge-utils
parent0958e6109c9ed8c82342d17a1205e3c4b8baa3f0 (diff)
downloadbuildroot-novena-9785f71c7a7a0eebf496d45e516b83c8019f6468.tar.gz
buildroot-novena-9785f71c7a7a0eebf496d45e516b83c8019f6468.zip
bridge: remove useless strip and use correct definition for uninstall
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bridge-utils')
-rw-r--r--package/bridge-utils/bridge.mk17
1 files changed, 4 insertions, 13 deletions
diff --git a/package/bridge-utils/bridge.mk b/package/bridge-utils/bridge.mk
index 925de0649..1d633ddab 100644
--- a/package/bridge-utils/bridge.mk
+++ b/package/bridge-utils/bridge.mk
@@ -13,18 +13,9 @@ BRIDGE_INSTALL_TARGET:=YES
BRIDGE_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install
BRIDGE_CONF_OPT:=--with-linux-headers=$(LINUX_HEADERS_DIR)
-$(eval $(call AUTOTARGETS,package,bridge))
-
-ifeq ($(BR2_ENABLE_DEBUG),)
-# bridge has no install-strip target
-$(BRIDGE_HOOK_POST_INSTALL): $(BRIDGE_TARGET_INSTALL_TARGET)
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/sbin/brctl
- touch $@
-endif
-
-# bridge has no uninstall target
-$(BRIDGE_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define BRIDGE_UNINSTALL_TARGET_CMDS
rm -f $(addprefix $(TARGET_DIR)/usr/,lib/libbridge.a \
include/libbridge.h man/man8/brctl.8 sbin/brctl)
- rm -f $(BRIDGE_TARGET_INSTALL_TARGET) $(BRIDGE_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,bridge))