summaryrefslogtreecommitdiffstats
path: root/package/bridge-utils/bridge-utils.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-19 22:53:07 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-20 22:47:09 +0200
commit53b26022965cdbeafe5e584d77354c68d229805b (patch)
tree2a980bd8729a0e95703363cc9b06f65ec6a2900e /package/bridge-utils/bridge-utils.mk
parent11bdfeaf3bb4271fca0e4063d699bff6df4fb9df (diff)
downloadbuildroot-novena-53b26022965cdbeafe5e584d77354c68d229805b.tar.gz
buildroot-novena-53b26022965cdbeafe5e584d77354c68d229805b.zip
bridge-utils: normalize package name
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bridge-utils/bridge-utils.mk')
-rw-r--r--package/bridge-utils/bridge-utils.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/bridge-utils/bridge-utils.mk b/package/bridge-utils/bridge-utils.mk
new file mode 100644
index 000000000..680749393
--- /dev/null
+++ b/package/bridge-utils/bridge-utils.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# bridge-utils
+#
+#############################################################
+
+BRIDGE_UTILS_VERSION = 1.5
+BRIDGE_UTILS_SOURCE = bridge-utils-$(BRIDGE_UTILS_VERSION).tar.gz
+BRIDGE_UTILS_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/bridge
+BRIDGE_UTILS_AUTORECONF = YES
+BRIDGE_UTILS_CONF_OPT = --with-linux-headers=$(LINUX_HEADERS_DIR)
+
+define BRIDGE_UTILS_UNINSTALL_TARGET_CMDS
+ rm -f $(addprefix $(TARGET_DIR)/usr/,lib/libbridge.a \
+ include/libbridge.h share/man/man8/brctl.8 sbin/brctl)
+endef
+
+$(eval $(call AUTOTARGETS,package,bridge-utils))