summaryrefslogtreecommitdiffstats
path: root/package/boost
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-01-30 17:58:22 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-30 17:58:22 +0100
commit4aadcac1684e4af54baa7e42b5e0fb73aa4b33b3 (patch)
tree17f21befed76d021780a472988ba1af1a1aa4cd7 /package/boost
parent0e80ba177970516e74e280f8091c12d22261380c (diff)
downloadbuildroot-novena-4aadcac1684e4af54baa7e42b5e0fb73aa4b33b3.tar.gz
buildroot-novena-4aadcac1684e4af54baa7e42b5e0fb73aa4b33b3.zip
boost: fix build with ccache
Drop quotes around TARGET_CXX as the boost buildsystem does handle spaces in the compiler command name, but treats it as a single command (and errors out) if quotes are used and ccache enabled. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/boost')
-rw-r--r--package/boost/boost.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 4bbc86904..4577f2dcc 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -52,7 +52,7 @@ BOOST_FLAGS += $(if $(BOOST_WITHOUT_FLAGS_COMMASEPERATED), --without-libraries=$
define BOOST_CONFIGURE_CMDS
(cd $(@D) && ./bootstrap.sh $(BOOST_FLAGS))
- echo "using gcc : $(TARGET_CC_VERSION) : \"$(TARGET_CXX)\" : <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > $(@D)/user-config.jam
+ echo "using gcc : $(TARGET_CC_VERSION) : $(TARGET_CXX) : <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > $(@D)/user-config.jam
echo "" >> $(@D)/user-config.jam
endef