summaryrefslogtreecommitdiffstats
path: root/package/bonnie
diff options
context:
space:
mode:
authorMartin Hicks <mort@bork.org>2011-01-31 15:32:06 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-26 11:39:48 +0200
commit4bc799856b3ba9378b1d03dac7069d15500cbeeb (patch)
treeae00e35b07903f9388b2d267fc1a2eb612c90947 /package/bonnie
parent1445e1455e1d80da7d9e8e4d90f7e38903440e07 (diff)
downloadbuildroot-novena-4bc799856b3ba9378b1d03dac7069d15500cbeeb.tar.gz
buildroot-novena-4bc799856b3ba9378b1d03dac7069d15500cbeeb.zip
package: add bonnie++
Closes #3379 A good filesystem performance benchmark program Signed-off-by: Martin Hicks <mort@bork.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bonnie')
-rw-r--r--package/bonnie/Config.in10
-rw-r--r--package/bonnie/bonnie.mk18
2 files changed, 28 insertions, 0 deletions
diff --git a/package/bonnie/Config.in b/package/bonnie/Config.in
new file mode 100644
index 000000000..9dda4b6cd
--- /dev/null
+++ b/package/bonnie/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_BONNIE
+ bool "bonnie++"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Filesystem tester
+
+ http://www.coker.com.au/bonnie++/
+
+comment "bonnie++ requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/bonnie/bonnie.mk b/package/bonnie/bonnie.mk
new file mode 100644
index 000000000..9a6188fa4
--- /dev/null
+++ b/package/bonnie/bonnie.mk
@@ -0,0 +1,18 @@
+#
+# bonnie++
+#
+
+BONNIE_VERSION = 1.03e
+BONNIE_SOURCE = bonnie++-$(BONNIE_VERSION).tgz
+BONNIE_SITE = http://www.coker.com.au/bonnie++/
+
+define BONNIE_INSTALL_TARGET_CMDS
+ install -D -m 755 $(@D)/bonnie++ $(TARGET_DIR)/usr/sbin/bonnie++
+ install -D -m 755 $(@D)/zcav $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+define BONNIE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/sbin/bonnie++ $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+$(eval $(call AUTOTARGETS,package,bonnie))