summaryrefslogtreecommitdiffstats
path: root/package/bmon
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-06-17 09:10:29 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-06-17 09:10:29 +0200
commit587863b039d3e9f1daabcada723450d633333473 (patch)
tree7b6d38a5cee0af84560099c655da6676e019c5d2 /package/bmon
parent3790e3ceed72f13767cdc41f8c05188d487c3a5e (diff)
downloadbuildroot-novena-587863b039d3e9f1daabcada723450d633333473.tar.gz
buildroot-novena-587863b039d3e9f1daabcada723450d633333473.zip
bmon: link dynamically unless explicitly requested otherwise
Commit 009d8fceab4d (add --{enable,disable}-{shared,static} automatically) caused us to pass --enable-static in the normal (non-static) case as well, which bmon interpretes as a request to link the bmon program statically, bloating the image. Fix it by passing an extra --disable-static to bmon configure to nullify this. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bmon')
-rw-r--r--package/bmon/bmon.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/bmon/bmon.mk b/package/bmon/bmon.mk
index e9b10b014..97d4b0231 100644
--- a/package/bmon/bmon.mk
+++ b/package/bmon/bmon.mk
@@ -9,6 +9,11 @@ BMON_SOURCE = bmon-$(BMON_VERSION).tar.gz
BMON_SITE = http://distfiles.gentoo.org/distfiles
BMON_DEPENDENCIES = ncurses
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+# link dynamically unless explicitly requested otherwise
+BMON_CONF_OPT += --disable-static
+endif
+
define BMON_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/bmon
endef