summaryrefslogtreecommitdiffstats
path: root/package/blackbox
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-02 14:04:34 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-02 14:04:34 +0200
commitca3489da7cdad87979f3bb096bdd3c85b9b46f9b (patch)
tree87855ce863ace37ddb8ed0fbba9d2c60878da377 /package/blackbox
parent52b8d0478a28d5c8bb29983ad9527e0fa5fae528 (diff)
downloadbuildroot-novena-ca3489da7cdad87979f3bb096bdd3c85b9b46f9b.tar.gz
buildroot-novena-ca3489da7cdad87979f3bb096bdd3c85b9b46f9b.zip
blackbox: needs iconv if !locale
Closes #2101 At the same time fix dependencies so it can be built without a local X server, and a comment is shown if C++ support isn't enabled. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/blackbox')
-rw-r--r--package/blackbox/Config.in5
-rw-r--r--package/blackbox/blackbox.mk6
2 files changed, 10 insertions, 1 deletions
diff --git a/package/blackbox/Config.in b/package/blackbox/Config.in
index bf237c53a..70f7eb4b5 100644
--- a/package/blackbox/Config.in
+++ b/package/blackbox/Config.in
@@ -2,8 +2,13 @@ config BR2_PACKAGE_BLACKBOX
bool "blackbox"
depends on BR2_PACKAGE_XORG7
depends on BR2_INSTALL_LIBSTDCPP
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+ select BR2_PACKAGE_XLIB_LIBX11
help
Blackbox is a fast, lightweight window manager for the X
Window System.
http://blackboxwm.sourceforge.net/
+
+comment "blackbox requires a toolchain with C++ support enabled"
+ depends on BR2_PACKAGE_XORG7 && !BR2_INSTALL_LIBSTDCPP
diff --git a/package/blackbox/blackbox.mk b/package/blackbox/blackbox.mk
index 41deb5860..e3c8c341b 100644
--- a/package/blackbox/blackbox.mk
+++ b/package/blackbox/blackbox.mk
@@ -14,6 +14,10 @@ BLACKBOX_INSTALL_TARGET:=YES
BLACKBOX_CONF_OPT:=--x-includes=$(STAGING_DIR)/usr/include/X11 \
--x-libraries=$(STAGING_DIR)/usr/lib
-BLACKBOX_DEPENDENCIES:=xserver_xorg-server
+BLACKBOX_DEPENDENCIES = xlib_libX11
+
+ifneq ($(BR2_ENABLE_LOCALE),y)
+BLACKBOX_DEPENDENCIES += libiconv
+endif
$(eval $(call AUTOTARGETS,package,blackbox))