summaryrefslogtreecommitdiffstats
path: root/package/bison
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-28 14:07:13 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-28 14:07:13 +0000
commit79e2d802ae7e376a413c02097790493e1f65c3a4 (patch)
tree419b543f2665588ed9cfa7a595648442a8f4ea4a /package/bison
parent0629a673ae2380274fcc73205ebb19bd5494b786 (diff)
downloadbuildroot-novena-79e2d802ae7e376a413c02097790493e1f65c3a4.tar.gz
buildroot-novena-79e2d802ae7e376a413c02097790493e1f65c3a4.zip
- fix a few -clean targets.
- bash build is not parallel-safe
Diffstat (limited to 'package/bison')
-rw-r--r--package/bison/bison.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/bison/bison.mk b/package/bison/bison.mk
index 2a764e0eb..cdc78eadd 100644
--- a/package/bison/bison.mk
+++ b/package/bison/bison.mk
@@ -58,7 +58,8 @@ $(TARGET_DIR)/$(BISON_TARGET_BINARY): $(BISON_DIR)/$(BISON_BINARY)
bison: uclibc $(TARGET_DIR)/$(BISON_TARGET_BINARY)
bison-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) uninstall
+ -$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BISON_DIR) uninstall
+ rm -f $(TARGET_DIR)/$(BISON_TARGET_BINARY)
-$(MAKE) -C $(BISON_DIR) clean
bison-dirclean: