summaryrefslogtreecommitdiffstats
path: root/package/bison
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-17 13:21:56 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-22 23:00:52 +0100
commit2a92cee21a24daa0ef6e49a08c8c298fcee91c63 (patch)
tree21c2e16fcf4c40910068afb2025455f943fca3c5 /package/bison
parent15bcaba70ab5c5ec7d3872700c01fd26eefd3bb3 (diff)
downloadbuildroot-novena-2a92cee21a24daa0ef6e49a08c8c298fcee91c63.tar.gz
buildroot-novena-2a92cee21a24daa0ef6e49a08c8c298fcee91c63.zip
bison: bump to version 2.4.3
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bison')
-rw-r--r--package/bison/Config.in4
-rw-r--r--package/bison/bison-2.4.3-uclibc-sched_param-def.patch19
-rw-r--r--package/bison/bison.mk6
3 files changed, 26 insertions, 3 deletions
diff --git a/package/bison/Config.in b/package/bison/Config.in
index edea4f6f9..e8aa0b60f 100644
--- a/package/bison/Config.in
+++ b/package/bison/Config.in
@@ -1,8 +1,12 @@
config BR2_PACKAGE_BISON
bool "bison"
+ depends on BR2_USE_WCHAR
help
General-purpose parser generator that converts a
grammar description for an LALR context-free grammar into a C
program to parse that grammar.
http://www.gnu.org/software/bison/
+
+comment "bison requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/bison/bison-2.4.3-uclibc-sched_param-def.patch b/package/bison/bison-2.4.3-uclibc-sched_param-def.patch
new file mode 100644
index 000000000..50652d8ba
--- /dev/null
+++ b/package/bison/bison-2.4.3-uclibc-sched_param-def.patch
@@ -0,0 +1,19 @@
+uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
+and is not needed too per standard. gnulib attempts to use it but we have to account
+for it because in this case uclibc does not behave like glibc.
+
+-Khem
+
+http://bugs.gentoo.org/336484
+
+--- m4-1.4.14/lib/spawn.in.h
++++ m4-1.4.14/lib/spawn.in.h
+@@ -31,7 +31,7 @@
+
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+ But avoid namespace pollution on glibc systems. */
+-#ifndef __GLIBC__
++#if !defined __GLIBC__ || defined __UCLIBC__
+ # include <sched.h>
+ # include <signal.h>
+ #endif
diff --git a/package/bison/bison.mk b/package/bison/bison.mk
index 9e28e85d9..8849030a2 100644
--- a/package/bison/bison.mk
+++ b/package/bison/bison.mk
@@ -3,9 +3,9 @@
# bison
#
#############################################################
-BISON_VERSION:=2.3
-BISON_SOURCE:=bison-$(BISON_VERSION).tar.bz2
-BISON_SITE:=$(BR2_GNU_MIRROR)/bison
+
+BISON_VERSION = 2.4.3
+BISON_SITE = $(BR2_GNU_MIRROR)/bison
define BISON_DISABLE_EXAMPLES
echo 'all install:' > $(@D)/examples/Makefile