summaryrefslogtreecommitdiffstats
path: root/package/bison
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-12-04 21:39:02 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-04 21:46:36 +0100
commit2077f955ef64b48c3832e0be31a18aaf04d786da (patch)
tree5ea1db0a625f334f73a3e2c3361beb4e5751cc87 /package/bison
parent2c6390a5d0c01420879e9f23bc89afb19976da4a (diff)
downloadbuildroot-novena-2077f955ef64b48c3832e0be31a18aaf04d786da.tar.gz
buildroot-novena-2077f955ef64b48c3832e0be31a18aaf04d786da.zip
bison: fix m4 dependency
Bison needs m4 (at runtime). In addition, the bison 2.5 configure script checks for m4 4.1.6 or newer, and bails out otherwise, but ends up looking at whatever the build host has rather than the cross version, which might not be the correct version (or even available). Fix it by short circuiting the check. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bison')
-rw-r--r--package/bison/Config.in1
-rw-r--r--package/bison/bison.mk5
2 files changed, 6 insertions, 0 deletions
diff --git a/package/bison/Config.in b/package/bison/Config.in
index e8aa0b60f..da0ac3f1e 100644
--- a/package/bison/Config.in
+++ b/package/bison/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_BISON
bool "bison"
depends on BR2_USE_WCHAR
+ select BR2_PACKAGE_M4
help
General-purpose parser generator that converts a
grammar description for an LALR context-free grammar into a C
diff --git a/package/bison/bison.mk b/package/bison/bison.mk
index 759592e16..c277e96ad 100644
--- a/package/bison/bison.mk
+++ b/package/bison/bison.mk
@@ -7,11 +7,16 @@
BISON_VERSION = 2.5
BISON_SITE = $(BR2_GNU_MIRROR)/bison
+BISON_CONF_ENV += ac_cv_path_M4=/usr/bin/m4
+BISON_DEPENDENCIES += m4
+
define BISON_DISABLE_EXAMPLES
echo 'all install:' > $(@D)/examples/Makefile
endef
BISON_POST_CONFIGURE_HOOKS += BISON_DISABLE_EXAMPLES
+HOST_BISON_DEPENDENCIES += host-m4
+
$(eval $(call AUTOTARGETS))
$(eval $(call AUTOTARGETS,host))