summaryrefslogtreecommitdiffstats
path: root/package/binutils
diff options
context:
space:
mode:
authorChris Zankel <chris@zankel.net>2012-11-20 08:31:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-21 11:08:50 +0100
commitfdd5bc948ed5fa3d14f9bfa09968f8216fb08ae1 (patch)
tree5af2cc6172a6674e70ff790bb0f2d7ea18d6fe45 /package/binutils
parent5e0f1e1fcfbaca2b33397b3076a55b23b0e02cd8 (diff)
downloadbuildroot-novena-fdd5bc948ed5fa3d14f9bfa09968f8216fb08ae1.tar.gz
buildroot-novena-fdd5bc948ed5fa3d14f9bfa09968f8216fb08ae1.zip
xtensa: use uppercase for configurations and modified overlay structure
Except for architecture and processor names, buildroot uses capitalized configuration names, so change the macro names for xtensa to follow that standard. Change the overlay file to have a subdirectory for each component (gdb, binutils, gcc, etc.) to make it more future-prove. Signed-off-by: Chris Zankel <chris@zankel.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/binutils')
-rw-r--r--package/binutils/binutils.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 82f8fd234..92e0a7483 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -68,11 +68,11 @@ define BINUTILS_INSTALL_TARGET_CMDS
endef
endif
-XTENSA_CORE_NAME = $(call qstrip, $(BR2_xtensa_core_name))
+XTENSA_CORE_NAME = $(call qstrip, $(BR2_XTENSA_CORE_NAME))
ifneq ($(XTENSA_CORE_NAME),)
define BINUTILS_XTENSA_PRE_PATCH
- tar xf $(BR2_xtensa_overlay_dir)/xtensa_$(XTENSA_CORE_NAME).tar \
- -C $(@D) bfd include ld
+ tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(XTENSA_CORE_NAME).tar \
+ -C $(@D) --strip-components=1 binutils
endef
HOST_BINUTILS_PRE_PATCH_HOOKS += BINUTILS_XTENSA_PRE_PATCH
endif