summaryrefslogtreecommitdiffstats
path: root/package/binutils
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2012-06-08 01:52:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-23 15:14:51 +0200
commitb7b640d8126659ca0803d8bad158917f50d43298 (patch)
treea5c8b18dd946053d153f0ef7c5c08bc9c004770c /package/binutils
parentd9c38d615af90782d62839a7b7836a24698b6416 (diff)
downloadbuildroot-novena-b7b640d8126659ca0803d8bad158917f50d43298.tar.gz
buildroot-novena-b7b640d8126659ca0803d8bad158917f50d43298.zip
Remove REAL_GNU_TARGET_NAME
Instead of providing two variables, make GNU_TARGET_NAME give the real target name, and remove REAL_GNU_TARGET_NAME altogether. Signed-off-by: Richard Braun <rbraun@sceen.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/binutils')
-rw-r--r--package/binutils/binutils.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 1c8a79d07..3293e185c 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -27,8 +27,8 @@ BINUTILS_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
# We need to specify host & target to avoid breaking ARM EABI
BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
- --host=$(REAL_GNU_TARGET_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --target=$(GNU_TARGET_NAME) \
--enable-shared \
$(BINUTILS_EXTRA_CONFIG_OPTIONS)
@@ -40,7 +40,7 @@ endif
# "host" binutils should actually be "cross"
# We just keep the convention of "host utility" for now
HOST_BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
- --target=$(REAL_GNU_TARGET_NAME) \
+ --target=$(GNU_TARGET_NAME) \
--disable-shared --enable-static \
--with-sysroot=$(STAGING_DIR) \
$(BINUTILS_EXTRA_CONFIG_OPTIONS)