summaryrefslogtreecommitdiffstats
path: root/package/binutils
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-10-02 23:19:10 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-02 23:19:10 +0200
commita1c10778092702f8856c1cc92126ef9801952d74 (patch)
treec7c6d26f32f28b7bb8f241f48e1474b1980cdd22 /package/binutils
parent1c20b39cf31bff85a8cf35e3bb2d8a9bbf436b16 (diff)
downloadbuildroot-novena-a1c10778092702f8856c1cc92126ef9801952d74.tar.gz
buildroot-novena-a1c10778092702f8856c1cc92126ef9801952d74.zip
binutils: build host version statically
Otherwise we end up with libbfd/libopcodes in host/usr/$BUILD/$TARGET/lib, used by the binaries. Unfortunately it also adds rpaths, which first look in the build directory before here, causing trouble if the toolchain is used outside BR (E.G. for a SDK) and the build directory location reused for another incompatible build (E.G. another ARCH), as the binutils binaries then end up using the wrong libs. Fix it by linking statically instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/binutils')
-rw-r--r--package/binutils/binutils.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 2d60ce074..5123568ec 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -30,6 +30,7 @@ endif
# We just keep the convention of "host utility" for now
HOST_BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
--target=$(REAL_GNU_TARGET_NAME) \
+ --disable-shared --enable-static \
$(BR2_CONFIGURE_STAGING_SYSROOT) \
$(BINUTILS_EXTRA_CONFIG_OPTIONS)