summaryrefslogtreecommitdiffstats
path: root/package/bind
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-05-05 10:54:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-05 22:57:54 +0200
commit80ebf12906afc3a1e5f4e5682d4c5dc0779a556a (patch)
tree6c70232232c688576a5eb87055c2b8ba5fb04d0b /package/bind
parent9edf482d6b210d16a22fdf561da2a2f0fb84824d (diff)
downloadbuildroot-novena-80ebf12906afc3a1e5f4e5682d4c5dc0779a556a.tar.gz
buildroot-novena-80ebf12906afc3a1e5f4e5682d4c5dc0779a556a.zip
bind: fix build failure for static+openssl
Bind just links to openssl libraries without checking it's dependencies. This works when doing shared builds since the linker picks the deps up, but fails badly on static builds. So just define LIBS="-lz" when openssl is enabled. Fixes: http://autobuild.buildroot.net/results/a9a166f932e0b6727ae8e470ce748418797875b9/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bind')
-rw-r--r--package/bind/bind.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index 8a66534eb..f6895945a 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -30,7 +30,7 @@ endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
BIND_DEPENDENCIES += openssl
- BIND_CONF_OPT += --with-openssl=$(STAGING_DIR)/usr
+ BIND_CONF_OPT += --with-openssl=$(STAGING_DIR)/usr LIBS="-lz"
else
BIND_CONF_OPT += --with-openssl=no
endif