summaryrefslogtreecommitdiffstats
path: root/package/bind
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/bind
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/bind')
-rw-r--r--package/bind/bind.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index c0632b9a1..a5cf09d7a 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -36,6 +36,7 @@ $(BIND_DIR2)/Makefile: $(BIND_DIR2)/.unpacked
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--libdir=/lib \
--includedir=/include \
@@ -78,9 +79,9 @@ $(TARGET_DIR)/lib/libdns.so: $(STAGING_DIR)/lib/libdns.so
cd $(STAGING_DIR)/lib; \
cp -a libdns*so* libisc*so* libbind9*so* \
liblwres*so* $(TARGET_DIR)/lib
-
+
bind-lib: $(STAGING_DIR)/lib/libdns.so $(TARGET_DIR)/lib/libdns.so
-
+
bind: uclibc bind-bin bind-lib
bind-clean: