summaryrefslogtreecommitdiffstats
path: root/package/berkeleydb
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-04-25 04:30:33 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-25 16:45:24 +0200
commit4608c4c1a4191c8d8e0a23cc9161bc7cccbedefc (patch)
tree1b74d679956714e994e45323ed7d7737e30af267 /package/berkeleydb
parent9f160affcc78e8e503d1e0d082b10f8c6209fed1 (diff)
downloadbuildroot-novena-4608c4c1a4191c8d8e0a23cc9161bc7cccbedefc.tar.gz
buildroot-novena-4608c4c1a4191c8d8e0a23cc9161bc7cccbedefc.zip
berkeleydb: add option for tools install
Add an option to install (or not) the berkeleydb binary tools. The default is no since most of the time/application just need the library and it helps save some space in the target. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/berkeleydb')
-rw-r--r--package/berkeleydb/Config.in6
-rw-r--r--package/berkeleydb/berkeleydb.mk13
2 files changed, 19 insertions, 0 deletions
diff --git a/package/berkeleydb/Config.in b/package/berkeleydb/Config.in
index 9568d4425..a597abbe8 100644
--- a/package/berkeleydb/Config.in
+++ b/package/berkeleydb/Config.in
@@ -5,3 +5,9 @@ config BR2_PACKAGE_BERKELEYDB
applications.
http://www.sleepycat.com/products/db.shtml
+
+config BR2_PACKAGE_BERKELEYDB_TOOLS
+ bool "install tools"
+ depends on BR2_PACKAGE_BERKELEYDB
+ help
+ Install berkeleydb tools, mostly useful for debugging purposes.
diff --git a/package/berkeleydb/berkeleydb.mk b/package/berkeleydb/berkeleydb.mk
index b2b0a45c2..d73789654 100644
--- a/package/berkeleydb/berkeleydb.mk
+++ b/package/berkeleydb/berkeleydb.mk
@@ -8,6 +8,9 @@ BERKELEYDB_SITE = http://download.oracle.com/berkeley-db
BERKELEYDB_SOURCE = db-$(BERKELEYDB_VERSION).NC.tar.gz
BERKELEYDB_SUBDIR = build_unix
BERKELEYDB_INSTALL_STAGING = YES
+BERKELEYDB_BINARIES = db_archive db_checkpoint db_deadlock db_dump \
+ db_hotbackup db_load db_log_verify db_printlog db_recover db_replicate \
+ db_stat db_tuner db_upgrade db_verify
# build directory can't be the directory where configure are there, so..
define BERKELEYDB_CONFIGURE_CMDS
@@ -33,6 +36,16 @@ define BERKELEYDB_CONFIGURE_CMDS
$(SED) 's/\.lo/.o/g' $(@D)/build_unix/Makefile
endef
+ifneq ($(BR2_PACKAGE_BERKELEYDB_TOOLS),y)
+
+define BERKELEYDB_REMOVE_TOOLS
+ rm -f $(addprefix $(TARGET_DIR)/usr/bin/, $(BERKELEYDB_BINARIES))
+endef
+
+BERKELEYDB_POST_INSTALL_TARGET_HOOKS += BERKELEYDB_REMOVE_TOOLS
+
+endif
+
ifneq ($(BR2_HAVE_DOCUMENTATION),y)
define BERKELEYDB_REMOVE_DOCS