summaryrefslogtreecommitdiffstats
path: root/package/bcusdk
diff options
context:
space:
mode:
authorGregory Hermant <gregory.hermant@calao-systems.com>2013-03-24 11:34:06 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 22:57:14 +0100
commit94e147012bd45a5b95d257af1589d5d368b2614d (patch)
treef6dfb40c728d88184670464b4735a5a37733c7f5 /package/bcusdk
parent468e9595be307b06ffd8bdcd6b7cac624e6549cc (diff)
downloadbuildroot-novena-94e147012bd45a5b95d257af1589d5d368b2614d.tar.gz
buildroot-novena-94e147012bd45a5b95d257af1589d5d368b2614d.zip
bcusdk: new package
[Peter: tweak comment] [Thomas: various fixes/improvements] Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bcusdk')
-rw-r--r--package/bcusdk/Config.in22
-rw-r--r--package/bcusdk/bcusdk.mk26
2 files changed, 48 insertions, 0 deletions
diff --git a/package/bcusdk/Config.in b/package/bcusdk/Config.in
new file mode 100644
index 000000000..cf082e7dc
--- /dev/null
+++ b/package/bcusdk/Config.in
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_BCUSDK
+ bool "bcusdk"
+ depends on BR2_INSTALL_LIBSTDCPP
+ select BR2_PACKAGE_LIBPTHSEM
+ help
+ A free development environment for the Bus Coupling Units of
+ the European Installation Bus.
+
+ The European Installation Bus EIB is a home and building
+ automation bus system. It is optimized for low-speed control
+ applications like lighting and blinds control.
+
+ BCUs (Bus Coupling Units) are standardized, generic
+ platforms for embedded EIB devices. They include the entire
+ physical layer network interface, power supply and a
+ microcontroller with an implementation of the EIB protocol
+ stack stored in the ROM.
+
+ http://www.auto.tuwien.ac.at/~mkoegler/eib/
+
+comment "bcusdk requires a toolchain with C++ support"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/bcusdk/bcusdk.mk b/package/bcusdk/bcusdk.mk
new file mode 100644
index 000000000..3e0714313
--- /dev/null
+++ b/package/bcusdk/bcusdk.mk
@@ -0,0 +1,26 @@
+#############################################################
+#
+# bcusck
+#
+#############################################################
+
+BCUSDK_VERSION = 0.0.5
+BCUSDK_SOURCE = bcusdk_$(BCUSDK_VERSION).tar.gz
+BCUSDK_SITE = http://www.auto.tuwien.ac.at/~mkoegler/eib/
+BCUSDK_LICENSE = GPLv2+
+BCUSDK_LICENSE_FILES = COPYING
+BCUSDK_INSTALL_STAGING = YES
+BCUSDK_CONF_OPT = --enable-onlyeibd --enable-ft12 --enable-pei16 \
+ --enable-eibnetip --enable-eibnetipserver \
+ --enable-eibnetiptunnel --without-pth-test \
+ --with-pth=$(STAGING_DIR)/usr
+
+BCUSDK_DEPENDENCIES = libpthsem
+
+define BCUSDK_REMOVE_EXAMPLES
+ $(RM) -rf $(TARGET_DIR)/usr/share/bcusdk
+endef
+
+BCUSDK_POST_INSTALL_TARGET_HOOKS += BCUSDK_REMOVE_EXAMPLES
+
+$(eval $(autotools-package))