summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-10 22:39:53 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-11 06:01:08 +0200
commitef785f61ad7290508b2640d00403b9a957fcdab1 (patch)
tree622dfa3a37ed0fbfd61d3aad60e5d44ec0a0c531 /package/bash
parent0f5a2ea7765c0d429607998647f8db1197b25a24 (diff)
downloadbuildroot-novena-ef785f61ad7290508b2640d00403b9a957fcdab1.tar.gz
buildroot-novena-ef785f61ad7290508b2640d00403b9a957fcdab1.zip
Do not let packages remove man pages, info pages and documentation
The cleanup of $(TARGET_DIR)/usr/share/man, $(TARGET_DIR)/usr/man, $(TARGET_DIR)/usr/share/info, $(TARGET_DIR)/usr/info, $(TARGET_DIR)/usr/share/doc and $(TARGET_DIR)/usr/doc is already done globally in the main Makefile. Therefore, there's no need to handle that on a per-package basis. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index b7fc71687..5abae559b 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -81,14 +81,7 @@ $(TARGET_DIR)/$(BASH_TARGET_BINARY): $(BASH_DIR)/$(BASH_BINARY)
rm -f $(TARGET_DIR)/bin/bash*
mv $(TARGET_DIR)/usr/bin/bash* $(TARGET_DIR)/bin/
(cd $(TARGET_DIR)/bin; /bin/ln -fs bash sh)
-ifneq ($(BR2_HAVE_INFOPAGES),y)
- rm -rf $(TARGET_DIR)/usr/share/info
-endif
-ifneq ($(BR2_HAVE_MANPAGES),y)
- rm -rf $(TARGET_DIR)/usr/share/man
-endif
rm -rf $(TARGET_DIR)/share/locale
- rm -rf $(TARGET_DIR)/usr/share/doc
# If both bash and busybox are selected, make certain bash wins
# the fight over who gets to own the /bin/sh symlink.